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UNIT 1 
OVERVIEW 

  
Introduction In this unit, you will learn about the Expense Assignment System, Version IV 

(EAS IV) Repository, its background, and how and why it functions. 

  
Unit Objective Upon completion of this unit, you will be able to describe the EAS IV 

Repository. 

  
In this Unit This unit includes the following lesson: 
 

Lesson See Page 

Lesson A:  The EAS IV Repository Description 1-3 
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LESSON A 
THE EAS IV REPOSITORY DESCRIPTION 

Overview 

  
Introduction In this lesson, you will learn about the EAS IV Repository, its environment, 

and its data load process. 

  
Lesson 
Objective 

Upon completion of this lesson, you will be able to do the following: 
• Describe the EAS IV Repository  

• Describe the EAS IV Repository environment 

• Describe the EAS IV Repository data transfer and load process 

   
Order of Topics This lesson includes the following topics: 

 

Topic See Page 

The EAS IV Repository  1-4 

The EAS IV Repository Environment 1-5 

The EAS IV Repository Database Load 1-6 
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The EAS IV Repository  

  
Introduction In this topic, you will learn about the EAS IV Repository. 

   
Description The EAS IV Repository provides the ability to query Medical Expense and 

Performance Reporting System (MEPRS) data in detailed and aggregated 
form and to formulate the data into a variety of reports.  MEPRS data, which 
originate from EAS IV at each Department of Defense (DoD) medical 
treatment facility (MTF) and dental treatment facility (DTF), consist mainly 
of MTF and DTF financial, workload, and personnel information. 

The EAS IV Repository replaces the functionality of MEPRS Executive 
Query System, Version III (MEQS III).  MEQS III used MEPRS data from 
Expense Assignment System, Version III (EAS III) to create query and 
reporting capability similar to the EAS IV Repository.  In an effort to update 
technology and maintain compatibility, the EAS IV Repository is replacing 
MEQS III. 
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The EAS IV Repository Environment 

  
Introduction In this topic, you will learn about the EAS IV Repository environment. 

   
Description The EAS IV Business Objects Repository resides on a Microsoft Windows 

NT client/server system.  Utilizing Informix databases, which reside on a 
Hewlett-Packard UNIX (HP-UX) server and the Windows NT server, the 
EAS IV Repository is accessed through user workstations using the Informix 
Client Connect, Version 9.1.4 or greater, connectivity software.  Transmission 
Control Protocol/Internet Protocol (TCP/IP) allows Business Objects, a 
Windows-based graphical user interface (GUI) query tool, to access all EAS 
IV Repository data. 

The HP-UX server with the Informix database stores all MEPRS data, which 
are received from MTFs and DTFs through an automated transfer and data 
load process.  Instead of having an EAS IV Repository server onsite, MTFs 
and DTFs connect through TCP/IP to the HP-UX server. 

Business Objects 5.1.5 is commercial off-the-shelf (COTS) software that 
resides on the client workstation and displays the data that are collected from 
the EAS IV Repository server and transferred by Informix Client Connect.  In 
Business Objects 5.1.5, data are called objects, and objects are grouped into 
classes.  Classes are grouped hierarchically to make up the EAS IV 
Repository universe. 
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The EAS IV Repository Database Load 

  
Introduction In this topic, you will learn about the EAS IV Repository database load. 

  
Description The EAS IV Repository server receives data directly from individual MTF 

and DTF EAS IV servers through the Transmission function.  At the 
scheduled transmission time, allocated data are sent to the EAS IV Repository 
server. The server polls hourly to take in all received transmissions but then 
holds the transmissions until a nightly automated database load.  The database 
load collects all the data and loads the data into the EAS IV Repository 
server.  

Because there is no required date and time to transmit data, the EAS IV 
Repository can house new, updated data every day depending on when site 
personnel transmit their monthly data.  The time the EAS IV Repository 
displays updated data also depends on the MTF’s or DTF’s time zone and 
location in relation to the server’s time zone and location. For example, if a 
site in Japan transmits data at their local time close of business on Monday 
the first, the data misses the EAS IV Repository server data load because 
Japan is 14 hours ahead of Eastern Standard time (EST). By EST, the server 
would receive the Japan site data at 3 in the morning on Tuesday the second. 
The server would have already processed data for the first. Therefore, the 
Japan site data may not be available to the Japan site until the afternoon of the 
second or the morning of the third. 

Because of the nature of MEPRS data, a large volume of server storage space 
is required to hold the data from Transmission jobs and EAS IV Repository 
query and report data.  Therefore, query and report information is housed on a 
Windows NT server, and the database is housed on an HP-UX server.  The 
Informix client connectivity software connects an MTF or DTF workstation 
to the Windows NT server, and then it connects to the HP-UX server if 
database data are requested.  In addition, data from Broadcast Agent, a report 
transmission scheduling function, are housed on a second Windows NT 
server.  See unit 9 for more information about Broadcast Agent. 

Continued on next page 
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The EAS IV Repository Database Load, Continued 

 
Description The following diagram displays the flow of data in the EAS IV Repository: 
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UNIT 2 
THE EAS IV REPOSITORY UNIVERSE 

Overview 

  
Introduction In this unit, you will learn about Business Objects 5.1.5 and the EAS IV 

Repository universe. 

  
Unit Objectives Upon completion of this unit, you will be able to do the following: 

• Describe Business Objects 5.1.5 

• Describe the EAS IV Repository universe 

• Describe the classes and objects in the EAS IV Repository 
universe 

  
In This Unit This unit includes the following lesson: 
 

Lesson See Page 

Lesson A:  The EAS IV Repository and Business Objects 
5.1.5 

2-3 
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LESSON A 
THE EAS IV REPOSITORY AND BUSINESS OBJECTS 5.1.5 

  
Introduction  In this lesson, you will learn about Business Objects 5.1.5 and how it relates 

to the EAS IV Repository. 

  
Lesson 
Objectives 

Upon completion of this lesson, you will be able to do the following: 
• Describe Business Objects 5.1.5 

• Describe the relationship between Business Objects 5.1.5 and the 
EAS IV Repository 

• Describe the EAS IV Repository Universe 

• Describe the EAS IV Repository Universe classes and objects 

  
Order of Topics This lesson includes the following topics: 
 

Topic See Page 

What is Business Objects 5.1.5? 2-4 

The EAS IV Repository Universe 2-5 
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What is Business Objects 5.1.5? 

  
Introduction In this topic, you will learn about Business Objects 5.1.5. 

  
Definition Business Objects 5.1.5 is a Windows GUI COTS software application, 

created to provide query and reporting capability for a variety of information. 

  
Description The EAS IV Repository uses Business Objects 5.1.5 to provide query and 

reporting capability for MEPRS data.  Just as with MEQS III, the Business 
Objects software is merely a tool that enables the end-user to search through 
MEPRS data and format the data in a variety of meaningful ways that allow 
for data integrity checks and decision support. 

Business Objects 5.1.5 is configured to house information hierarchically.  All 
pieces of data are referred to as objects.  Objects are then grouped logically 
into classes, and the classes are grouped into universes.  For the purposes of 
the EAS IV Repository, there are 24 classes, 16 sub-classes, and 1 universe, 
the EAS IV Repository. 
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The EAS IV Repository Universe 

  
Introduction In this topic, you will learn about the EAS IV Repository universe. 

  
Definition In Business Objects, a universe is a total or partial representation of a 

relational database used for a particular application or group of users.  For the 
EAS IV Repository, the universe represents access to the database with 
MEPRS data that come from EAS IV.  The EAS IV Repository users access 
the data through the universe in Business Objects 5.1.5. 

  
Universe 
Hierarchy 

The following diagram displays a portion of the EAS IV Repository universe 
hierarchy: 

 
   

 

Continued on next page 
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The EAS IV Repository Universe, Continued 

 
EAS IV 
Repository 
Universe 
Classes and 
Objects 

The EAS IV Repository universe holds 24 classes and 16 sub-classes.  Each 
class has its own objects, some of which are repeated from class to class, and 
others that are entirely individual.  The following table lists the classes, the 
definition of the classes, and the objects within each class. 

Class  Class Description Objects in Class 

01 Location 
 

Contains DMIS facility 
information by Fiscal 
Year.  The objects in 
this class relate to 
EAS IV MTFs and 
DTFs that transmit EAS 
IV data files 

• Parent DMIS ID 
• Fiscal Year 
• DMIS ID 
• DMIS Name 
• Installation Name 
• Facility Type Code 
• Facility City 
• Facility Zip1 Code 
• Facility Zip2 Code 
• Facility Location 

Code 
• US Flag Code 
• Service Code 
• Service Description 
• Health Service 

Region 
• UIC 
• Regional Medical 

Code 
• Regional Medical 

Description 
• HSO Code 
• HSO Description 
• Major Command 

Code 
• Major Command 

Description 

Continued on next page 
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The EAS IV Repository Universe, Continued 

  
EAS IV Repository Universe Classes and Objects (continued) 
 

Class Class Description Objects in Class 

02 Load Status Contains 12 months of 
information regarding 
the load date, job ID 
and job status of 
EAS IV Transmissions 
by DMIS ID and Fiscal 
Year 

• Fiscal Year 
• Parent DMIS ID 
• Status 01 
• Job ID 01 
• Load Date 01 
• Status 02 
• Job ID 02 
• Load Date 02 
• Status 03 
• Job ID 03 
• Load Date 04 
• Status 04 
• Job ID 04 
• Load Date 04 
• Status 05 
• Job ID 05 
• Load Date 05 
• Status 06 
• Job ID 06 
• Load Date 06 
• Status 07 
• Job ID 07 
• Load Date 07 
• Status 08 
• Job ID 08 

Continued on next page 
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The EAS IV Repository Universe, Continued 

  
EAS IV Repository Universe Classes and Objects (continued) 

 

Class  Class Description Objects in Class 

02 Load Status, 
Continued 

Contains 12 months of 
information regarding 
the load date, job ID 
and job status of 
EAS IV Transmissions 
by DMIS ID and Fiscal 
Year 

• Load Date 08 
• Status 09 
• Job ID 09 
• Load Date 09 
• Status 10 
• Job ID 10 
• Load Date 10 
• Status 11 
• Job ID 11 
• Load Date 11 
• Status 12 
• Job ID 12 
• Load Date 12 

03 Rpting Components 
of Parent MTF 

Contains the reporting 
hierarchy for first 
through third level 
FCCs 

• Fiscal Year 
• 1st Level Functional 

Cost Code 
• 1st Level Functional 

Cost Code Desc 
• 2nd Level Functional 

Cost Code 
• 2nd Level Functional 

Cost Code Desc 
• 3rd Level Functional 

Cost Code 
• 3rd Level Functional 

Cost Code Desc 
• Cost Pool Indicator 

Continued on next page 
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The EAS IV Repository Universe, Continued 

  
EAS IV Repository Universe Classes and Objects (continued) 
 

Class Class Description Objects in Class 

04 Month Contains hierarchical 
Fiscal and calendar 
month objects 

• Fiscal Quarter 
• Calendar Month 
• Cal Month Mm 
• Fiscal Month 
• Month Abbreviation 
• Month Description 

05 Common Expense 
Elements 

Contains many DoD 
common expense 
elements 

• Fiscal Year 
• DoD SEEC 
• DoD SEEC 

Description 
• DoD SEEC Category 
• DoD SEEC Category 

Description 
• Schedule Type Code 
• Fixed Cost Percent 
• DoD PEC 
• DoD PEC 

Description 
• DoD BSL Code 
• DoD BSL 

Description 
• SOF 
• SOF Description 

Continued on next page 
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The EAS IV Repository Universe, Continued 

  
EAS IV Repository Universe Classes and Objects (continued) 
 

Class Class Description Objects in Class 

06 Expense Detail Contains expense 
accepted data 

• Fiscal Year 
• Fiscal Month 
• Parent DMIS ID 
• 4th Level Functional 

Cost Code 
• DMIS ID 
• 3rd Level Functional 

Cost Code 
• Capitation Category 
• Capitation 

Description 
• Direct Expense 

Month Net 
• Direct Obligation 

Month Net 
• Purified Expense 
• Stepdown Expense 

Contributed 
• Stepdown Expense 

From D Accounts 
• Stepdown Expense 

From E Accounts 

Continued on next page 
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The EAS IV Repository Universe, Continued 

  
EAS IV Repository Universe Classes and Objects (continued) 
 

Class Class Description Objects in Class 

07 Personnel Detail Contains personnel 
accepted data 

• Fiscal Year 
• Fiscal Month 
• Parent DMIS ID 
• 4th Level Functional 

Cost Code 
• DMIS ID 
• Personnel Category 
• Personnel Category 

Description 
• Skill type Code 
• Skill type Code 

Description 
• Skill type Suffix 

Code Skill type Map 
Description 

• Duty Indicator 
• Duty Indicator 

Description 
• Service Occupation 

Code 
• Service Occupation 

Code Description 
• DoD Occupation 

Code 
• DoD Occupation 

Code Description 
• Capitation Category 
• Capitation 

Description 

Continued on next page 
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The EAS IV Repository Universe, Continued 

  
EAS IV Repository Universe Classes and Objects (continued) 

 

Class  Class Description Objects in Class 

07 Personnel Detail, 
Continued 

Contains personnel 
accepted data 

• Assigned FTE 
• Available FTE 
• Nonavailable Leave 

FTE 
• Nonavailable Other 

FTE 
• Nonavailable Sick 

FTE  
• Purified Available 

FTE  
• Available Salary 

Expense 
• Nonavailable Salary 

Expense  
• Available Salary 

Expense 
• Nonavailable Salary 

Expense 

Continued on next page 
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The EAS IV Repository Universe, Continued 

  
EAS IV Repository Universe Classes and Objects (continued) 

 

Class  Class Description Objects in Class 

08 Common Expense 
Allocation Keys 

Contains data relative 
to commonly used 
expense allocation data 

• Fiscal Year 
• Parent DMIS ID 
• 4th Level Functional 

Cost Code 
• DMIS ID 
• 3rd Level Functional 

Cost Code 
• Expense Indicator 
• Expense Indicator 

Description 
• Skill type Code 
• Skill type Code 

Description 
• Providing DMIS ID 
• Providing 4th Level 

Functional Cost Code 
• Capitation Category 
• Capitation 

Description 
09 Expense Allocated Contains net month 

expense amounts 
received by FCCs 
during allocation 

• Fiscal Month 
• Month Net Expense 

Continued on next page 
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The EAS IV Repository Universe, Continued 

  
EAS IV Repository Universe Classes and Objects (continued) 
 

Class  Class Description Objects in Class 

10 Personnel Allocated Contains the FTE data 
elements by personnel 
category, skill type, 
Service occupation, and 
duty indicator 

 

• Fiscal Year 
• Fiscal Month 
• Personnel Category 
• Personnel Category 

Description 
• Skill type Code 
• Skill type Code 

Description 
• Skill type Suffix 

Code 
• Skill type Map 

Description 
• Duty Indicator 
• Duty Indicator 

Description 
• Service Unique 

Occupation Code 
• Service Occupation 

Code Description 
• DoD Occupation 

Code 
• DoD Occupation 

Code Description 
• Assigned FTE 
• Available FTE 
• Nonavailable Leave 

FTE 
• Nonavailable Other 

FTE 
• Nonavailable Sick 

FTE 

Continued on next page 
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The EAS IV Repository Universe, Continued 

  
EAS IV Repository Universe Classes and Objects (continued) 
 

Class Class Description Objects in Class 

11 Account Subset 
Definition 

Contains the Account 
Subset Definition 
(ASD) table by Fiscal 
Year 

• Fiscal Year 
• Parent DMIS ID 
• 4th Level Functional 

Cost Code 
• 4th Level Functional 

Cost  Code 
Description 

• DMIS ID 
• 3rd Level Functional 

Cost Code 
• 3rd Level Functional 

Cost Code 
Description 

• Reporting Category 
• ASN 
• Data Set Identifier 

12 Service Unit Cost Contains summary-
level expenses based on 
Service unit codes 

• Fiscal Year 
• Fiscal Month 
• Parent DMIS ID 
• 4th Level Functional 

Cost Code  
• DMIS ID 
• DoD SEEC 
• Service Unit Code 
• Service Unit Code 

Description 
• Skill type Code 
• Skill type Code 

Description 

Continued on next page 
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The EAS IV Repository Universe, Continued 

  
EAS IV Repository Universe Classes and Objects (continued) 

 

Class  Class Description Objects in Class 

12 Service Unit Cost, 
Continued 

Contains summary-
level expenses based on 
Service unit codes 

• Statistical Amount 
• Direct Expense 
• Cost Pool  
• Expense From D 

Accounts 
• Expense From E 

Accounts 
• Total Expense 

13 Patient Acuity Contains data related to 
the severity of a 
patient’s condition and 
to the level of nursing 
care required for the 
patient 

• Fiscal Year 
• Fiscal Month 
• Parent DMIS ID 
• 4th Level Functional 

Cost Code 
• DMIS ID 
• 3rd Level Functional 

Cost Code 
• Patient Acuity 

Category 
• Patient Numbers 
• Nursing Hours 

Continued on next page 
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The EAS IV Repository Universe, Continued 

  
EAS IV Repository Universe Classes and Objects (continued) 
 

Class Class Description Objects in Class 

14 DRG Cost FCC Contains DRG-related 
data, which compares 
demographic, 
diagnostic, and 
therapeutic 
characteristics per a 
patient’s length of stay 
(LOS) and the amount 
of resources consumed. 
These data are used to 
credit inpatient 
workload and to 
allocate resources with 
the DoD Military 
Health System (MHS) 

• Fiscal Year 
• Fiscal Month 
• Parent DMIS ID 
• DMIS ID 
• 3rd Level Functional 

Cost Code 
• DRG Code 
• Case Mix Index 
• FCC Average Length 

of Stay 
• FCC DRG RWP 
• FCC DRG Weight 
• FCC Total RWP 
• DRG Expense per 

Disposition 
• FCC Total DRG 

Expense 
• Inpatient Expense per 

Disposition 
• Prof Salaries per 

Disposition 
• FCC Total 

Disposition 

Continued on next page 
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The EAS IV Repository Universe, Continued 

  
EAS IV Repository Universe Classes and Objects (continued) 
 

Class Class Description Objects in Class 

15 Data Sets Contains data related to 
an MTF’s or DTF’s 
data sets 

• Fiscal Year 
• Fiscal Month 
• Parent DMIS ID 
• 4th Level Functional 

Cost Code 
• DMIS ID 
• 3rd Level Functional 

Cost Code 
• Providing DMIS ID 
• Beneficiary Category 

Code 
• Beneficiary Category 

Description 
• Data Set ID 
• Raw Statistical 

Amount 
• Weighted Statistical 

Amount 

Continued on next page 
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The EAS IV Repository Universe, Continued 

  
EAS IV Repository Universe Classes and Objects (continued) 
 

Class Class Description Objects in Class 

16 Expense Pure Contains data related to 
pure financial expenses, 
which are non-allocated 
expenses 

• Pure Record ID 
• Fiscal Year 
• Fiscal Month 
• Parent DMIS ID 
• DMIS ID 
• 4th Level Functional 

Cost Code 
• Obligation Fiscal 

Year 
• Service Code 
• Schedule Type Code 
• SUEE Code 
• Service Unique PEC 
• Service BSL Code 
• SOF 
• RC/CC 
• Expense YTD 
• Obligation YTD 

Continued on next page 
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The EAS IV Repository Universe, Continued 

 
EAS IV Repository Universe Classes and Objects (continued) 
 

Class Class Description Objects in Class 

17 Ambulatory CPT 
Workload 

Contains data related to 
weighted ambulatory 
visits 

• Fiscal Year 
• Parent DMIS ID 
• Fiscal Month 
• Providing DMIS ID 
• Providing 4th Level 

Functional Cost Code 
• Beneficiary Category 

Code 
• Beneficiary Category 

Description 
• CPT Code 
• CPT Modifier 
• CPT Code Type 
• CPT AMA Short 

Name 
• CPT DoD Name 
• CPT Weight 
• Raw Statistical 

Amount 
• Weighted Statistical 

Amount 
• Cost per Weighted 

Unit 
• Total Procedure Cost 

Continued on next page 



EAS IV Repository Functional User’s Guide 
 

May 2003 2-21 105-03-001 

The EAS IV Repository Universe, Continued 

 
EAS IV Repository Universe Classes and Objects (continued) 

 

Class  Class Description Objects in Class 

18 Ancillary CPT 
Workload 

Contains data related to 
weighted pharmacy, 
lab, and radiology 
procedures 

• Fiscal Year 
• Parent DMIS ID 
• Fiscal Month 
• Providing DMIS ID 
• Providing 4th Level 

Functional Cost Code 
• Beneficiary Category 

Code 
• Beneficiary Category 

Description 
• CPT Code 
• CPT Modifier 
• CPT Code Type 
• CPT AMA Short 

Name 
• CPT DoD Name  
• CPT Weight 
• Raw Statistical 

Amount 
• Weighted Statistical 

Amount 
• Cost per Weighted 

Unit 
• Total Procedure Cost 

Continued on next page 
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The EAS IV Repository Universe, Continued 

 
EAS IV Repository Universe Classes and Objects (continued) 
 

Class Class Description Objects in Class 

19 Respiratory / 
Pulmonary Workload 

Contains data related to 
weighted respiratory 
therapy and pulmonary 
function procedures 

• Fiscal Year 
• Parent DMIS ID 
• Fiscal Month 
• Providing DMIS ID 
• Providing 4th Level 

Functional Cost Code 
• Beneficiary Category 

Code 
• Beneficiary Category 

Description 
• Resp / Pulmonary 

Procedure Code 
• Resp / Pulm 

Procedure 
Description 

• Resp / Pulm 
Procedure  Weight 

• Raw Statistical 
Amount 

• Weighted Statistical 
Amount 

• Cost Per Weighted 
Unit 

• Total Procedure Cost 

Continued on next page 



EAS IV Repository Functional User’s Guide 
 

May 2003 2-23 105-03-001 

The EAS IV Repository Universe, Continued 

 
EAS IV Repository Universe Classes and Objects (continued) 
 

Class  Class Description Objects in Class 

20 FCC Expense 
Summary 

Contains a summary of 
all data by FCC 

• Fiscal Year 
• Fiscal Month 
• Parent DMIS ID 
• 4th Level Functional 

Cost Code 
• DMIS ID 
• 3rd Level Functional 

Cost Code 
• Direct Care Prof 

Salary 
• Direct Clinician 

Salary 
• Direct Medical 

Supply Expense 
• Direct Other Expense 
• Direct Other Lab 

Expense 
• Indirect Anc Lab 

Expense 
• Indirect Anc Other 

Expense 
• Indirect Anc Supply 

Expense 
• Indirect Supply 

Expense 
• Indirect Supply Lab 

Expense 
• Indirect Supply Other 

Expense 
• Total Expense 

Continued on next page 
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The EAS IV Repository Universe, Continued 

 
EAS IV Repository Universe Classes and Objects (continued) 

 

Class  Class Description Objects in Class 

21 FCC Summary Contains a summary of 
all data by FCCs 

• Fiscal Year 
• Fiscal Month 
• Parent DMIS ID 
• 4th Level Functional 

Cost Code 
• DMIS ID 
• 3rd Level Functional 

Cost Code 
• Admissions 
• Ancillary Procedures 

Count 
• Ancillary Weight 

Procedures 
• Assigned FTE 
• Available FTE 
• Dental Weight 

Procedures 
• Dispositions 
• Nonavailable Hosp 

FTE 
• Nonavailable Leave 

FTE 
• Nonavailable Other 

FTE 
• Nursing Patient 

Acuity 
• Occupied Bed Days 
• Outpatient Visits 
• Total Visits 

Continued on next page 
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The EAS IV Repository Universe, Continued 

 
EAS IV Repository Universe Classes and Objects (continued) 
 

Class Class Description Objects in Class 

21 FCC Summary, 
Continued 

Contains a summary of 
all data by FCCs 

• Administrative 
Clerical Salary 

• Clinical Salary 
• Direct Expense 
• Direct Obligations 
• Direct Care 

Professional Salary 
• Direct Care 

Paraprofessional 
Salary 

• Personnel Direct 
Expense 

• Purified Expense 
• Registered Nurse 

Salary 
• Stepdown Expense 

Contributed 
• Stepdown Expense 

From D 
• Stepdown Expense 

From E 

Continued on next page 
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The EAS IV Repository Universe, Continued 

 
EAS IV Repository Universe Classes and Objects (continued) 
 

Class  Class Description Objects in Class 

22 Facility Summary Contains a summary of 
data at the facility level 

• Fiscal Year 
• Fiscal Month 
• Parent DMIS ID 
• Admissions 
• Assigned FTE A 
• Assigned FTE B 
• Assigned FTE C 
• Assigned FTE D 
• Assigned FTE E 
• Assigned FTE F 
• Assigned FTE G 
• Dispositions 
• Occupied Bed Days 
• Outpatient Visits 
• Tot Available FTE A 
• Tot Available FTE B 
• Tot Available FTE C 
• Tot Available FTE D 
• Tot Available FTE E 
• Tot Available FTE F 
• Tot Available FTE G 
• Total Visits 

Continued on next page 
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The EAS IV Repository Universe, Continued 

 
EAS IV Repository Universe Classes and Objects (continued) 

 

Class  Class Description Objects in Class 

22 Facility Summary, 
Continued 

Contains a summary of 
data at the facility level 

• Direct Obligations A 
• Direct Obligations B 
• Direct Obligations C 
• Direct Obligations D 
• Direct Obligations E 
• Direct Obligations F 
• Direct Obligations G 
• Total Expense A 
• Total Expense B 
• Total Expense C 
• Total Expense D 
• Total Expense E 
• Total Expense F 
• Total Expense G 

Continued on next page 
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The EAS IV Repository Universe, Continued 

 
EAS IV Repository Universe Classes and Objects (continued) 
 

Class  Class Description Objects in Class 

23 Transmission Job Contains statistical 
information related to 
MTF and DTF EAS IV 
Transmissions 

• Process Job ID 
• Fiscal Year 
• Fiscal Month 
• Parent DMIS ID 
• Successful Data 

Extract 
• Service Start 
• Successful Repository 

Load Process 
• Successful Transmit 
• ASD Record Count 
• Ambulatory Record 

Count 
• Ancillary Record 

Count 
• Data Set Record 

Count 
• DRG Record Count 
• Expense Accepted 

Record Count 
• Expense Allocated 

Record Count 
• Expense Pure Record 

Count 
• Personnel Accepted 

Record Count 
• Respiratory/ 

Pulmonary Record 
Count 

Continued on next page 
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The EAS IV Repository Universe, Continued 

 
EAS IV Repository Universe Classes and Objects (continued) 

 

Class  Class Description Objects in Class 

23 Transmission Job, 
Continued 

Contains statistical 
information related to 
MTF and DTF EAS IV 
Transmissions 

• Service Unit Cost 
Record Count 

• Transmission 
Software Version nbr 

• Transmission Job ID 
• Transmission Status 
• User ID 
• Compressed File 

Name 
• Requested 

Transmission 
Timestamp 

• Scheduled Timestamp
• Transmission Service 

Timestamp 

Continued on next page 
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The EAS IV Repository Universe, Continued 

 
EAS IV Repository Universe Classes and Objects (continued) 

 

Class  Class Description Objects in Class 

24 Reference Only Contains all Reference 
data by fiscal year 

NOTE: This class 
contains 
subclasses.  
The 
subclasses are 
marked with 
* in the 
Objects in 
Class name 
column. 

• *Beneficiary 
Category 

• Beneficiary Category 
Code 

• Beneficiary Category 
Description 

• *Capitation Category 
• Capitation Category 
• Capitation 

Description 
• *CPT Year 
• Fiscal Year 
• CPT Code 
• CPT Code Modifier 
• CPT Code Type 
• CPT AMA Short 

Name  
• CPT DoD Name  
• CPT Weight 
• * Dental Code 
• Fiscal Year 
• Dental Code 
• Dental Code 

Description 
• Dental Code Owner 
• Dental Code DoD 

Weight 
• Activation Date 

Continued on next page 
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The EAS IV Repository Universe, Continued 

 
EAS IV Repository Universe Classes and Objects (continued) 

 

Class  Class Description Objects in Class 

24 Reference Only, 
Continued 

Contains all Reference 
data by Fiscal Year 

NOTE: This class 
contains 
subclasses. 
The 
subclasses are 
marked with 
* in the 
Objects in 
Class name 
column. 

• Deactivation Date 
• *DoD BSL  
• DoD BSL Code 
• DoD BSL 

Description 
• *DoD PEC  
• Fiscal Year 
• DoD PEC 
• DoD PEC 

Description  
• *DoD SEEC 
• Fiscal Year 
• DoD SEEC 
• DoD SEEC 

Description 
• DoD SEEC Category 
• DoD SEEC Category 

Description 
• Schedule Type Code 
• Fixed Cost Percent 
• *Duty Indicator 
• Duty Indicator 
• Duty Indicator 

Description 
• *Expense Indicator 
• Expense Indicator  

Continued on next page 
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The EAS IV Repository Universe, Continued 

 
EAS IV Repository Universe Classes and Objects (continued) 

 

Class  Class Description Objects in Class 

24 Reference Only, 
Continued 

Contains all Reference 
data by Fiscal Year 

NOTE: This class 
contains 
subclasses. 
The 
subclasses are 
marked with 
* in the 
Objects in 
Class name 
column. 

• Expense Indicator 
Description 

• *Functional Cost 
Codes 

• Fiscal Year  
• 1st Level Functional 

Cost Code 
• 1st Level Functional 

Cost Code Desc 
• 2nd Level Functional 

Cost Code  
• 2nd Level Functional 

Cost Code Desc 
• 3rd Level Functional 

Cost Code 
• 3rd Level Functional 

Cost Code Desc 
• *Personnel Category 
• Personnel Category 
• Personnel Category 

Description 
• *Resp / Pulm Codes 
• Fiscal Year  
• Resp / Pulm 

Procedure Code 
• Resp / Pulm 

Procedure 
Description 

Continued on next page 
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The EAS IV Repository Universe, Continued 

 
EAS IV Repository Universe Classes and Objects (continued) 

 

Class  Class Description Objects in Class 

24 Reference Only, 
Continued  

Contains all Reference 
data by Fiscal Year 

NOTE: This class 
contains 
subclasses. 
The 
subclasses are 
marked with 
* in the 
Objects in 
Class name 
column. 

• Resp / Pulm 
Procedure Weight 

• *Service Occupation 
Codes  

• Skill type Code 
• Service Code 
• DoD Occupation 

Code  
• DoD Occupation 

Code Description 
• Service Occupation 

Code 
• Service Occupation 

Code Description 
• *Service Unit Codes 
• Service Unit Code 
• Service Unit Code 

Description 
• *Skill Type 
• Fiscal Year 
• Skill type Code 
• Skill type Code 

Description 
• Skill type Suffix 

Code 
• Skill type Map 

Description 
• *SOF 
• SOF 
• SOF Description 
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UNIT 3 
GETTING STARTED WITH THE EAS IV REPOSITORY 

Overview 

  
Introduction In this unit, you will learn how to get started using the EAS IV Repository. 

  
Unit Objectives Upon completion of this unit, you will be able to do the following: 

• Log on to and off of Business Objects 5.1.5 

• Use the New Report Wizard 

  
In This Unit This unit includes the following lessons: 

 

Topic See Page 

Lesson A:  Accessing Business Objects 5.1.5 3-3 

Lesson B:  Selecting Reports 3-7 
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LESSON A 
ACCESSING BUSINESS OBJECTS 5.1.5 

Overview 

  
Introduction In this lesson, you will learn how to log on to and log off of Business 

Objects 5.1.5. 

  
Lesson 
Objectives 

Upon completion of this lesson, you will be able to do the following: 
• Log on to Business Objects 5.1.5 

• Log off of Business Objects 5.1.5 

  
Order of Topics This lesson includes the following topics: 
 

Topic See Page 

Logging on to Business Objects 5.1.5 3-4 

Logging off of Business Objects 5.1.5 3-6 
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Logging on to Business Objects 5.1.5 

  
Introduction In this topic, you will learn how to log on to Business Objects 5.1.5.  To 

access Business Objects 5.1.5 and the EAS IV Repository data, you must log 
on to Business Objects 5.1.5 with your Business Objects 5.1.5 user ID and 
your Business Objects password. 

  
Procedure The following table describes how to log on to Business Objects 5.1.5: 
 

Step Action 

1 On the workstation desktop, double-click the Business 
Objects 5.1.5 icon. 

2 In the User Identification window, in the User Name box, type 
your user name. 

 
NOTE: If you have multiple instances of Business Objects 5.x, 

then you will have a third field, Security Domain. The 
domain you choose in that box will affect the user IDs 
that populate in the User Name dropdown list.  

3 In the Password box, type your Business Objects password. 

Continued on next page 
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Logging on to Business Objects 5.1.5, Continued 

  
Procedure (continued) 
 

Step Action 

4 In the Security Domain box, click the down arrow. 

NOTE: If you do not have multiple Business Objects 5.x 
applications, then you will not see this field and you 
may skip step 4 and 5. 

5 In the list, select the Business Objects repository you want. 

6 Click OK. 
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Logging off of Business Objects 5.1.5 

  
Introduction In this topic, you will learn how to log off of Business Objects 5.1.5.  After 

you create and save your reports, you exit Business Objects by closing the 
program. 

  
Procedure The following table describes how to log off of Business Objects 5.1.5: 
 

Step Action 

1 In the Business Objects window, on the File menu, click Exit. 

NOTE: You may also click the Close Window icon ( ) in the 
upper-right corner of the Business Objects window. 
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LESSON B 
SELECTING REPORTS 

Overview 

  
Introduction In this lesson, you will learn how to use the New Report Wizard to select 

report formats and data providers. 

  
Lesson 
Objectives 

Upon completion of this lesson, you will be able to do the following: 
• Use the New Report Wizard to select a standard report 

• Use the New Report Wizard to select a standard report with a set 
default universe 

• Use the New Report Wizard to select a report template 

• Use the New Report Wizard to select a report template with a set 
default universe 

  
Order of Topics This lesson includes the following topics: 

 

Topic See Page 

Selecting a Standard Report 3-8 

Selecting a Standard Report With a Set Default Universe 3-12 

Selecting a Report Template 3-13 

Selecting a Report Template With a Set Default Universe 3-17 
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Selecting a Standard Report  

  
Introduction In this topic, you will learn how to use the New Report Wizard to select a 

standard report.  The New Report Wizard guides you through the report 
format selection process; however, the report does not appear until you create 
a query and run it.  See unit 4 for information on creating and running a 
query. 

   
Description The standard report in Business Objects 5.1.5 is a table report.  It is possible, 

however, to format your own standard report style.  See unit 8 for more 
information. 

  
Procedure The following table describes how to use the New Report Wizard to select a 

standard report: 

 

Step Action 

1 Log on to Business Objects 5.1.5. 

2 In the Business Objects window, on the File menu, click New. 

NOTE: You may also click the New icon ( ). 

Continued on next page 
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Selecting a Standard Report, Continued 

  
Procedure (continued) 
 

Step Action 

3 In the New Report Wizard, Create a New Report window, click 
Begin. 

 
NOTE: The default Business Objects 5.1.5 report layout is 

Generate a standard report.  If a default universe has 
been selected, this window appears with more options; 
see Selecting a Standard Report With a Set Default 
Universe. 

Continued on next page 
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Selecting a Standard Report, Continued 

  
Procedure (continued) 
 

Step Action 
4 In the New Report Wizard, Specify Data Access window, click 

Next. 

 
NOTE: While it is possible to retrieve data using methods other 

than the default choice, Universe, refreshed MEPRS 
data can be retrieved only from the default selection.  

Continued on next page 
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Selecting a Standard Report, Continued 

  
Procedure (continued) 
 

Step Action 

5 In the New Report Wizard, Select a Universe window, in the 
Available Universes list, select EAS IV Repository. 

6 Click Set as My Default Universe. 

7 Click Finish. 
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Selecting a Standard Report With a Set Default Universe 

  
Introduction In this topic, you will learn how to use the New Report Wizard to select a 

standard report format when a default universe is set. 

  
Definition A default universe is a preselected universe, which is used no matter which 

type of report format you choose.  The only universe option for the EAS IV 
Repository is the EAS IV Repository universe.  Using a default universe 
makes the process for selecting a standard report faster. 

  
Procedure The following table describes how to select a standard report when a default 

universe is already set: 
 

Step Action 
1 Log on to Business Objects 5.1.5. 

2 In the Business Objects window, on the File menu, click New. 

NOTE: You may also click the New icon ( ). 

3 In the New Report Wizard, Create a New Report window, click 
Finish. 
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Selecting a Report Template 

  
Introduction In this topic, you will learn how to use the New Report Wizard to select a 

report template.  Although a standard table format is the default setting for 
Business Objects 5.1.5, you can select one of nine other established report 
format templates to create a different look or presentation in your report.  You 
also have the option to create your own template and add it to the list of 
templates in the New Report Wizard, or browse and select a template saved in 
another location.  See Unit 8, Templates, for information on creating and 
saving templates. 

  
Procedure The following table describes how to select a report template: 
 

Step Action 
1 Log on to Business Objects 5.1.5. 

2 In the Business Objects window, on the File menu, click New. 

NOTE: You may also click the New icon ( ). 

3 In the New Report Wizard, Create a New Report window, click 
Select a template. 

4 Click Begin. 

Continued on next page 
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Selecting a Report Template, Continued 

  
Procedure (continued) 
 

Step Action 
5 If you want to use an established template, in the New Report 

Wizard, Select a Template window, in the Available Templates 
list, select a template. 

6 If you want to browse for a template saved in another location, in 
the New Report Wizard, Select a Template window, click Browse. 

7 In the Browse for Folder window, in the list, select the template 
from its location. 

8 Click OK. 

9 Click Next. 

Continued on next page 
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Selecting a Report Template, Continued 

  
Procedure (continued) 
 

Step Action 
10 In the New Report Wizard, Specify Data Access window, click 

Next. 

Continued on next page 



EAS IV Repository Functional User’s Guide 
 

May 2003 3-16 105-03-001 

Selecting a Report Template, Continued 

  
Procedure (continued) 
 

Step Action 

11 In the New Report Wizard, Select a Universe window, in the 
Available Universes list, select EAS IV Repository. 

12 Click Finish. 
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Selecting a Report Template With a Set Default Universe 

  
Introduction In this topic, you will learn how to use the New Report Wizard to select a 

report template when a default universe is already set.  This process is similar 
to selecting a report with a set default universe. 

  
Procedure The following table describes how to select a report template with a set 

default universe: 
 

Step Action 
1 Log on to Business Objects 5.1.5. 

2 In the Business Objects window, on the File menu, click New. 

NOTE: You may also click the New icon ( ). 

3 In the New Report Wizard, Create a New Report window, under 
For the report layout, you can, click Select a template. 

4 Click Begin. 

Continued on next page 
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Selecting a Report Template With a Set Default Universe, 
Continued 

  
Procedure (continued) 
 

Step Action 
5 If you want to use an established template, in the New Report 

Wizard, Select a Template window, in the Available Templates 
list, select a template. 

6 If you want to browse for a template saved in another location, in 
the New Report Wizard, Select a Template window, click Browse. 

7 In the Browse for Folder window, in the list, select the template 
from its location. 

8 Click OK. 

9 Click Finish. 
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UNIT 4 
CREATING QUERIES 

Overview 

  
Introduction In this unit, you will learn how to create queries for EAS IV Repository data 

that combine with the formatting choices you make in the New Report 
Wizard to create EAS IV Repository reports. 

  
Unit Objectives Upon completion of this unit, you will be able to do the following: 

• Describe the Query Panel – EAS IV Repository Universe window 

• Work with queries 

  
In This Unit This unit includes the following lessons: 

 

Lesson See Page 

Lesson A:  Learning About Queries 4-3 

Lesson B:  Creating Queries 4-9 
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LESSON A 
LEARNING ABOUT QUERIES 

Overview 

  
Introduction In this lesson, you will learn about queries and the query setup window. 

  
Lesson 
Objectives 

Upon completion of this lesson, you will be able to do the following: 
• Describe a query 

• Describe the Query Panel – EAS IV Repository Universe window 

  
Order of Topics This lesson includes the following topics: 

 

Topic See Page 

What Is a Query? 4-3 

The Query Panel – EAS IV Repository Universe Window 4-4 
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What Is a Query? 

  
Introduction In this topic, you will learn about queries. 

  
Definition A query is a set of choices and criteria defined by a user to search and retrieve 

data stored in the server database. 

  
Description In Business Objects 5.1.5, you can create a query, which is like a set of 

questions and instructions, to gather information, which is then formatted into 
a report. 

To retrieve data from the EAS IV Repository Universe, you must make 
selections from the classes and objects in the universe.  Also, because the 
database is so large, you can apply conditions to narrow and specify the data 
in the report.  All queries are set up in the Query Panel – EAS IV Repository 
Universe window, which automatically generates after you click Finish in the 
New Report Wizard window.  See unit 3 for information on the New Report 
Wizard.  You can also access the Query Panel – EAS IV Repository Universe 
window from Report Manager.  See unit 5 for information on Report 
Manager. 

Business Objects 5.1.5 stores reports in a document, which is similar to 
storing a report in a file folder.  Just as you can have a multi-paged report on 
one topic in the folder, you can have multiple reports based on the same 
query.  You can also have separate report pages based on different topics, 
which is comparable to having multiple reports based on different queries, in 
one document.  It is also possible to have a mixture in one document with 
reports that may be based on the same or different queries.  See unit 5 for 
information on creating duplicate reports and inserting reports with different 
queries in a document. 
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The Query Panel – EAS IV Repository Universe Window 

  
Introduction In this topic, you will learn about the Query Panel – EAS IV Repository 

Universe window. 

  
Description The following diagram represents the three main sections in the EAS IV 

Repository Universe window: 

 

 
 
 

The Classes and Objects section is a list of all possible data choices you could 
include in your report.  The Result Objects section is the holding area for the 
selected data, which will be included in your report.  The Conditions section 
is the holding area for all the simple and complex conditions you place on the 
data in your query, which result in more specific report results. 

Continued on next page 
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The Query Panel – EAS IV Repository Universe Window, 
Continued 

  
Icon 
Description 

In addition to the three main sections of the EAS IV Repository Universe 
window, there is a helpful toolbar, on which only certain functions are 
available for the EAS IV Repository.  These include a function for setting 
additional options on the query and the ability to save the query or to view the 
query results without running the report. 

The following table describes the icons that can be used in the Query Panel – 
EAS IV Repository Universe window: 

 
Icon Name/Picture Description 

Show/Hide All Classes   Displays or hides the Classes and 
Objects section  

Show/hide help on selected item   Displays or hides help on a selected 
class or object 

Wrap Result Objects   Aligns objects in the Result Objects 
section so that you do not need to 
scroll horizontally to see all objects 

Simple Condition  Sets a simple condition on the 
selected result object 

Help  Provides help for the Business 
Objects 5.1.5 application 

Default Scope of Analysis  Sets the Drill Down level 

Scope of Analysis   Creates a complex data range for 
Drill Down 

Continued on next page 
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The Query Panel – EAS IV Repository Universe Window, 
Continued 

  
Icon Description (continued) 
 

Icon Name Description 

Options Provides formatting options before 
the query runs 

Save and Close Enables you to save the query if it is 
not possible to finish or run the query 
at the current time 

View Provides a view of query results 
without running the report, in 
addition to providing some 
scheduling options 

Run Sends the query to the database to 
retrieve results and then formats the 
results in a report 

Cancel Clears the query and returns the user 
to the New Report Wizard or the 
Business Objects window, if the New 
Report Wizard is disabled 
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LESSON B 
CREATING QUERIES 

Overview 

  
Introduction In this lesson, you will learn how to create queries. 

  
Lesson 
Objectives 

Upon completion of this lesson, you will be able to do the following: 
• Recognize classes and objects 

• Add, format, and delete Result Objects 

• Apply simple conditions 

• Apply complex conditions 

• Edit and delete condition statements 

• Set options on a query 

• Save a query  

• Use View to access Data Manager functions 

• Run a query 

• Cancel a query 

  
Order of Topics This lesson includes the following topics: 

Topic See Page 

Viewing Classes and Objects 4-11 

Adding a Result Object 4-13 

Formatting a Result Object 4-15 

Deleting a Result Object 4-17 

Query Conditions 4-18 

Applying Simple Conditions 4-19 

Applying Complex Conditions 4-21 

Continued on next page 
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Overview, Continued 

  
Order of Topics (continued) 
 

Topic See Page 

Editing a Condition Statement 4-27 

Deleting a Condition Statement 4-28 

Setting Query Options 4-29 

Saving a Query 4-32 

Using the Data Manager Through the Query Panel 4-33 

Running a Query 4-36 

Canceling a Query 4-37 
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Viewing Classes and Objects 

  
Introduction  In this topic, you will learn how to view classes and objects in the Query 

Panel – EAS IV Repository Universe window. 

  
Description Each Universe contains groups of EAS IV Repository data called classes.  

The classes are further subdivided into objects.  For example, a class might be 
class 06 Expense Detail, and some of the objects within that class might be 
Direct Expense Month Net and Direct Obligation Month Net.  Objects are 
also arranged in a hierarchical order so that you can perform detailed data 
analysis.  You can include entire classes, represented by folder icons ( ), in 
a report or choose objects from classes. 

The following two types of objects are available for EAS IV  Repository data: 
• Dimension objects  

• Measure objects  

Dimension objects, represented by a blue cube, retrieve data that provide the 
basis for analysis in a report.  Typically, dimension objects retrieve character-
type data such as names or dates.  Measure objects, represented by a pink dot, 
retrieve numeric data that are the result of calculations on data in the 
database.  For example, the measure objects might be Total Expenses or Total 
Obligations for an MTF or DTF. 

NOTE: Business Objects offers a third type of object represented by a green 
triangle, detail objects; however, these are not available for EAS IV 
Repository data. 

 Continued on next page 
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Viewing Classes and Objects, Continued 

  
Procedure The following table describes how to view classes and objects: 
 

Step Action 
1 In the Query Panel – EAS IV Repository Universe window, in the 

Classes and Objects list, click the plus icon (+) next to a class. 

NOTE: You may also double-click the class to open it. 

2 View the objects in the class. 
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Adding a Result Object 

  
Introduction In this topic, you will learn how to add objects to the Result Objects section 

from the Classes and Objects section of the Query Panel – EAS IV 
Repository Universe window. 

  
Definition Result Objects are the data that appear in a report after you run a query. 

   
Description EAS IV Repository data received from EAS IV are net month data, 

containing only amounts for a particular fiscal month and fiscal year for an 
MTF or DTF.  The EAS IV Repository allows for both net month and 
cumulative (year-to-date) data to be extracted from the database.  If you want 
net month data, add the Fiscal Month object to the Result Objects section.  If 
you want cumulative data, do not add the Fiscal Month object.  For net month 
and cumulative data, specify the fiscal month in the query conditions. 

  
Procedure The following table describes how to add a Result Object: 

 

Step Action 

1 If the Classes and Objects list is not visible, in the Query Panel – 
EAS IV Repository Universe window, click the Show/Hide All 

Classes icon ( ). 

Continued on next page 
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Adding a Result Object, Continued 

  
Procedure (continued) 
 

Step Action 
2 In the Classes and Objects list, do one of the following: 

  If Then  

  You want to add an entire 
class to the Result Objects 
section 

Drag and drop the folder to 
the Result Objects box. 

 

  You want to add a specific 
object to the Result Objects 
section 

a) Next to the folder 
containing the object, 
click the plus icon (+). 

NOTE: You can also 
double-click the 
folder. 

b) In the list, double-click 
the object. 

NOTE: You can also 
drag and drop 
the object to the 
Result Objects 
section. 
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Formatting a Result Object 

  
Introduction In this topic, you will learn how to format Result Objects. 

  
Description Business Objects automatically arranges items from left to right in a standard 

report, by the order they are added to the Result Objects section.  You may 
need to rearrange the objects before you run the query.  Objects are moved in 
the Result Objects section by dragging and dropping them to new locations.  
To display objects in the Result Objects section in rows and columns for 

easier viewing, select the Wrap Result Objects icon ( ).  The Wrap Result 
Objects function does not affect the way the data display in the report. 

  
Procedure for 
Wrapping 
Result Objects 

The following table describes how to wrap Result Objects: 

 
Step Action 

1 In the Query Panel – EAS IV Repository Universe window, click 

the Wrap Result Objects icon ( ). 

  
Procedure for 
Moving Result 
Objects 

The following table describes how to move Result Objects: 

 
Step Action 

1 In the Query Panel – EAS IV Repository Universe window, in the 
Result Objects section, drag and drop the object to a new position. 

 Continued on next page 
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Formatting a Result Object, Continued 

 
Procedure for 
Shaping Result 
Objects 

The following table describes how to extend the size of Result Objects: 

 
Step Action 

1 In the Query Panel – EAS IV Repository Universe window, in the 
Result Objects section, drag the right border. 

NOTE: The cursor must change to a horizontal arrow  (      ) 
before you can drag the border. 
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Deleting a Result Object 

  
Introduction In this topic, you will learn how to delete Result Objects from the Query 

Panel – EAS IV Repository Universe window. 

  
Procedure The following table describes how to delete a Result Object: 

 

Step Action 

1 In the Query Panel – EAS IV Repository Universe window, in the 
Result Objects section, right-click the object you want to delete. 

2 On the menu, click Remove. 
NOTE: You may also delete an object by dragging it back to the 

Classes and Objects section, or by selecting the object 
and then pressing Delete.  If a series of objects needs to 
be deleted, select the last of the objects in the series and 
hold down Delete.  You do not need to select each of the 
objects in the series. 
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Query Conditions 

  
Introduction In this topic, you will learn about query conditions. 

  
Description The Conditions section in the Query Panel – EAS IV Repository Universe 

window allows you to set parameters on your query, which result in more 
specific report data.  Another reason conditions are used is that with more 
specific query conditions, the database returns quicker results.   

You can set a complex condition on any Dimension object, whether it is in 
the Result Objects section or in the Classes and Objects list.  Alternatively, 
you can set a simple condition on any Dimension object in the Result Objects 
section.  It is also possible to combine complex and simple conditions into 
groups of conditions. 

  
Condition 
Statements 

Business Objects 5.1.5 writes simple condition statements for you, but you 
have to write your own complex condition statements with the prompts 
provided by Business Objects 5.1.5.  Regardless of whether the condition is 
simple or complex, condition statements generally consist of three parts: An 
object, an operator, and an operand. 

• The object is that to which the condition is applied. 

• The operator defines how to narrow the data. 

• The operand is the value(s) for which the query searches. 

The following are examples of condition statements: 
 4th Level Functional Cost Code matches pattern ‘AB_D’ 

Skill type code between 1 and 5 
The first example will supply only 4th Level FCCs that have A in the first 
level, B in the second level, any letter in the third level, and D in the fourth 
level. 

The second example will supply only those skill types that are 2, 3, or 4. 

NOTE: In instances where the operator cancels out the need for an operand, 
there are only two parts to the condition statement.  For example, 
Job Id 01 is null represents a two part condition statement with Job 
Id 01 as the object and is null as the operator. 
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Applying Simple Conditions 

  
Introduction In this topic, you will learn how to apply simple conditions.  Simple 

conditions can only be applied to result objects.  When you apply a simple 
condition, Business Objects creates and formats a condition statement for 
you.  Your involvement is limited to selecting an object, and a value or values 
from a list. 

   
Procedure The following table describes how to apply a simple condition: 
 

Step Action 

1 In the Query Panel – EAS IV Repository Universe window, in the 
Result Objects section, right-click the object to which you want to 
apply the condition. 

2 On the menu, click Apply Simple Condition. 

Continued on next page 
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Applying Simple Conditions, Continued 

  
Procedure (continued) 
 

Step Action 

3 In the List of Values <Object Name> window, select the value(s). 

 
NOTE: If the window has no list, click Refresh.  To select 

multiple values, press Ctrl and select each item.  In some 
windows, you can drag the pointer down the list to select 
multiple values. 

4 If you want to verify the values you selected in the list, click Show 
Selected Only. 

5 Click OK. 
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Applying Complex Conditions 

  
Introduction In this topic, you will learn how to apply complex conditions.  Complex 

conditions may be applied to any Dimension object in the Result Objects 
section or in the Classes and Objects list.  When applying a complex 
condition, though Business Objects prompts you on how to write the 
condition statement, it does not write it for you as it does with simple 
conditions. 

  
Description The following table describes the available operators for use when creating 

complex conditions: 
 

Operator Description 

Equal to Returns values that are equal to the 
value specified in the operand 

Different from Returns values that are different from 
the value specified in the operand 

In list Returns values that are equal to one 
of the values specified in the operand

Not in list Returns values that are different from 
(all) the values specified in the 
operand 

Less than Returns values that are less than the 
value specified in the operand 

Greater than Returns values that are greater than 
the value specified in the operand 

Less than or equal to Returns values that are less than or 
equal to the value specified in the 
operand 

Greater than or equal to Returns values that are greater than 
or equal to the value specified in the 
operand 

Continued on next page 
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Applying Complex Conditions, Continued 

  
Description  (continued) 
 

Operator Description 

Is not null Returns values that contain no empty 
rows 

Is null Returns values that contain empty 
rows 

Between Returns values that are between the 
specified values in operand 1 and 
operand 2 

Not between Returns values that are not between 
the values specified in operand 1 and 
operand 2 

Matches pattern Returns values that have the same 
pattern as a specified character string, 
which can contain wildcards such as 
% or _ 

Different from pattern Returns values that have a different 
pattern from that of a specified 
character string, which can contain 
wildcards such as % or _ 

Both Returns values that are equal to both 
value(s) specified in the operand 

Except Returns values that are different from 
the value(s) specified in the operand 

Continued on next page 
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Applying Complex Conditions, Continued 

 
Description The following table describes the available operands for use when creating 

complex conditions: 
 

Operand Description 

Type a new constant Compares the object’s values with 
the value(s) that you type 

Show list of values Compares the object’s values with 
the value(s) that you select in the 
object’s list of values 

Type a new prompt Compares the object’s values with 
one or more values that you enter 
when you run the query 

Show list of prompts Compares the object’s values with 
one or more values that you select 
when you run the query 

Select an object Compares the object’s values with 
the values of another object 

Create a subquery (ALL) Compares the object’s values with all 
the values returned by a subquery 

Create a subquery (ANY) Compares the object’s values with 
any of the values returned by a 
subquery 

Calculation Compares the object’s values with 
the results of a calculation such as 
sum, minimum, maximum, average, 
or count 

Continued on next page 
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Applying Complex Conditions, Continued 

  
Procedure The following table describes how to apply a complex condition: 
 

Step Action 

1 In the Query Panel – EAS IV Repository Universe window, in the 
Classes and Objects list, drag an object to the Conditions section. 

NOTE: The Classes and Objects list turns into the Operators list, 
and a <Select an Operator> prompt appears in the 
condition statement in the Conditions box. 

Continued on next page 
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Applying Complex Conditions, Continued 

  
Procedure (continued) 
 

Step Action 

2 In the Operators list, double-click an operator. 

NOTE: The Operators list turns into the Operands list, and a 
<Select an Operand> prompt appears.  The operands that 
appear depend on the operator you selected. 

3 In the Operands list, double-click the operand you want to use. 

Continued on next page 
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Applying Complex Conditions, Continued 

  
Procedure (continued) 
 

Step Action 

4  

  If Then  

  You chose Type a new 
constant 

a) In the condition statement, 
in the operand field, type 
a value. 

b) Press Enter. 

 

  You chose Show list of values a) In the List of Values 
<Name of Object> 
window, select the 
value(s). 

b) Click OK. 

 

  You chose Type a new 
prompt 

a) In the condition statement, 
in the operand field, type 
the prompt. 

NOTE: When typing a 
prompt, you type the 
instructions, not the 
value. 

b) Press Enter. 
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Editing a Condition Statement 

  
Introduction In this topic, you will learn how to edit a condition statement.  It is possible to 

change any part of a condition statement without deleting it and starting over. 

  
Procedure The following table describes how to edit a condition statement: 
 

Step Action 

1 If you want to change the object, in the Query Panel – EAS IV 
Repository Universe window, in the Conditions section, click the 
object section of the condition statement. 

2 In the Classes and Objects list, double-click the new object. 

3 If you want to change the operator, in the Query Panel – EAS IV 
Repository Universe window, in the Conditions section, click the 
operator section of the condition statement. 

4 In the Operators list, double-click the new operator. 

5 If you want to change the operand, in the Query Panel – EAS IV 
Repository Universe window, in the Conditions section, click the 
operand section of the condition statement. 

6 In the Operands list, double-click the new operand. 
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Deleting a Condition Statement 

  
Introduction In this topic, you will learn how to delete a condition statement. 

  
Procedure The following table describes how to delete a condition statement: 
 

Step Action 
1 In the Query Panel – EAS IV Repository Universe window, in the 

Conditions section, right-click the statement you want to delete. 

2 On the menu, click Delete. 
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Setting Query Options 

  
Introduction In this topic, you will learn how to set query options. 

  
Description Query options enable you to extend the possible ways your report can 

develop.  The following chart describes the possible query options: 
 

Option Description 

Duplicate/No Duplicate Rows The report includes or excludes rows 
of the same information. 

Do Not Retrieve Data You create the query, but it does not 
gather information from the database 
to create a report.  This function is 
helpful when you want to create a 
query but schedule it to run at a later 
time. 

Delete Trailing Blanks The report omits any blank cells at 
the end of rows. 

Partial Results You select the number of rows you 
want to see in the report.  Default 
results in the total amount of rows.  
Other allows you to type a number. 

Continued on next page 
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Setting Query Options, Continued 

 
Procedure The following table describes how to set query options: 
 

Step Action 

1 In the Query Panel – EAS IV Repository Universe window, click 
Options. 

2  

  If Then  

  You want to exclude duplicate 
rows of data in your query 
result 

In the Rows section, select No 
Duplicate Rows. 

 

  You want partial results In the Partial Results section, 
select the appropriate number 
of rows.  If you select Other, 
type the number of rows you 
want to display in the query. 
NOTE: If you do not limit 

the results, the 
query chooses a 
preselected default 
value. 

 

  

Continued on next page 
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Setting Query Options, Continued 

  
Procedure (continued) 
 

Step Action 

 If Then 2, cont. 

 You want to generate the 
Structured Query Language 
(SQL) statement for the query 
without connecting to the 
database 

Select Do Not Retrieve Data. 
 

 

  You want to delete spaces that 
appear at the end of a row of 
data 

Select Delete Trailing Blanks.  

  

3 Click OK. 
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Saving a Query 

  
Introduction In this topic, you will learn how to save a query. 

  
Description Saving a query enables you to exit a query and return to it at a later time to 

complete or run the query.  Queries are linked to reports in documents, so it is 
necessary to save the document as well if you intend to exit Business 
Objects 5.1.5.  Saving a query causes the query to not retrieve data.  You 
must run the query to retrieve data in a report. 

  
Procedure The following table describes how to save a query: 
 

Step Action 

1 In the Query Panel – EAS IV Repository Universe window, create 
your query. 

2 Click Save and Close. 

3 In the Business Objects - document <number> - <user ID> 
window, on the File menu, click Save As. 

4 In the Save As window, in the Save in box, select the location 
where you want to save the document. 

5 In the File name box, type the name you wish to apply to the 
document. 

6 Click Save. 
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Using the Data Manager Through the Query Panel 

  
Introduction In this topic, you will learn how to access and use the Data Manager. 

  
Description In the Data Manager window, you can view and make changes to a query 

before performing it.  Clicking the View icon in the Query Panel – EAS IV 
Repository Universe window is one way to access the Data Manager.  You 
can view the number of rows the report displays, edit the query, make 
changes to the query name and universe, and schedule the report to 
automatically refresh all before running the query. 

  
Procedure The following table describes how to use the Data Manager: 

 

Step Action 

1 In the Query Panel – EAS IV Repository Universe window, click 
View. 

2 In the Data Manager window, on the result tab, do one of the 
following: 

Continued on next page 
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Using the Data Manager Through the Query Panel, Continued 

  
Procedure (continued) 
 

Step Action 

 If Then  2, cont. 

 You want to edit the query a) Click Edit. 
b) In the Query Panel – 

EAS IV Repository 
Universe window, make 
your edits. 

 

  You want to cancel the query 
and return to the previous 
window 

Click Cancel.  

  You want to perform the 
query and create the report 

Click OK.  

  You want to delete the data 
and create a blank report 

Click Purge. 

NOTE: This option is only 
available if the 
query has already 
been performed. 

 

  You want to retrieve or 
refresh the data 

Click Refresh.  

  

3 Click the Definition tab. 

Continued on next page 
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Using the Data Manager Through the Query Panel, Continued 

 
Procedure (continued) 

 

Step Action 

4 If you want to rename the query, under General, in the Name box, 
type a new query name. 

5 If you want to set an automatic refresh time for your query, click 
Automatic Refresh. 

NOTE: Business Objects must be running in order for the report 
to refresh. 

6 Set the time and date. 

7 Click OK. 
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Running a Query 

  
Introduction In this topic, you will learn how to run a query.  Running a query causes a 

query that you have set up to poll the database, search and retrieve results, 
and format them into a report style. 

   
Procedure The following table describes how to run a query: 
 

Step Action 

1 In the Query Panel – EAS IV Repository Universe window, click 
Run. 
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Canceling a Query 

  
Introduction In this topic, you will learn how to cancel a query.  Canceling a query causes 

all query selections to delete and closes the query panel window. 

  
Procedure The following table describes how to cancel a query: 
 

Step Action 

1 In the Query Panel – EAS IV Repository Universe window, click 
Cancel. 
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UNIT 5 
FORMATTING REPORTS 

Overview 

  
Introduction In this unit, you will learn how to format reports. 

  
Unit Objectives Upon completion of this unit, you will be able to do the following: 

• Describe report layout 

• Describe the various ways to select cells and blocks 

• Format report styles 

  
In this Unit This unit includes the following lessons: 
 

Lesson See Page 

Lesson A:  Learning About Report Layout 5-3 

Lesson B:  Selecting Cells and Blocks 5-13 

Lesson C:  Formatting Reports 5-19 
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LESSON A 
LEARNING ABOUT REPORT LAYOUT 

Overview 

  
Introduction In this lesson, you will learn about the structural layout of reports. 

  
Lesson 
Objectives 

Upon completion of this lesson, you will be able to do the following: 
• Describe report layout 

• Insert additional reports in a document 

• Describe Report Manager 

  
Order of Topics This lesson includes the following topics: 
 

Topic See Page 

Report Layout 5-4 

Inserting Reports in a Document 5-5 

About Report Manager 5-8 
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Report Layout 

  
Introduction In this topic, you will learn about the standard layout of Business 

Objects 5.1.5 reports. 

  
Description Reports are stored in documents.  A document can contain one report, 

different views of the same report, completely different reports, or a 
combination of the latter.  The concept is similar to a file folder full of a 
variety of papers, including single paged, related, and unrelated documents. 

After you run a query, Business Objects 5.1.5 automatically generates a 
document with the report in the format that you chose in the New Report 
Wizard. 

 
 

  

Document 
Title 

Report 
Manager 

Report 
tab 
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Inserting Reports in a Document 

  
Introduction In this topic, you will learn how to insert different kinds of reports into a 

Business Objects 5.1.5 document.  It is possible to insert an identical copy of 
a report, a report that runs off of a different query on the same universe, or a 
report from a non-EAS IV Repository data provider, like Microsoft Excel. 

  
Definitions A duplicate report is an exact copy of a report and runs off of the same query.  

If changes are made to the query, it affects both reports.  However, formatting 
changes are applied individually. 

An inserted report runs off of a different query and may have a different 
report format. 

  
Procedure to 
Duplicate a 
Report 

The following table describes how to duplicate a report in a document: 

 

Step Action 

1 In a report, on the Insert menu, click Duplicate Report. 
NOTE: You may also right-click a report tab and click Duplicate 

Report. 

Continued on next page 
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Inserting Reports in a Document, Continued 

 
Procedure to 
Insert a Report 

The following table describes how to insert a report in a document: 

 

Step Action 

1 In a report, on the Insert menu, click Insert Report. 
NOTE: You may also right-click a report tab and click Insert 

Report. 

2  

  If Then  

  You want to insert a new table 
report 

a) Click the Insert Table icon  

( ). 
b) In the white area of the 

report, drag out a 
medium-sized space. 

c) In the New Table Wizard, 
Insert a New Table 
window, follow the 
prompts. 

 

  You want to insert a new 
chart report 

a) Click the Insert Chart icon 
( ). 

b) In the white area of the 
report, drag out a 
medium-sized space. 

c) In the New Chart Wizard, 
Insert a New Chart 
window, follow the 
prompts. 

 

     

Continued on next page 
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Inserting Reports in a Document, Continued 

  
Procedure to Insert a Report (continued) 
 

Step Action 

    

 If Then  2, cont. 

 You want to insert a crosstab a) Click the Insert Crosstab 
icon ( ). 

b) In the white area of the 
report, drag out a 
medium-sized space. 

c) In the New Crosstab 
Wizard, Insert a New 
Crosstab, follow the 
prompts. 

 

  

   



EAS IV Repository Functional User’s Guide 
 

May 2003 5-8 105-03-001 

About Report Manager 

  
Introduction In this topic, you will learn about Report Manager. 

  
Description Report Manager helps you manage the layout of your report by allowing you 

to add and subtract Result Objects in a report, and to easily navigate around 
reports in a document.  In addition, Report Manager can return you to the 
query for any of your reports to edit the query or make a new query. 

There are two tabs in Report Manager, the Data tab and the Map tab.  The 
Data tab displays all the queries and their variables in the document and all 
the formulas.  The Map tab displays the reports in the document.  The Map 
tab can also display the structure of the report(s). You activate and deactivate 

Report Manager by clicking the Report Manager icon ( ) on the Standard 
toolbar. 

  
Procedure to 
Insert an 
Object in a 
Report with 
Report 
Manager 

The following table describes how to insert an object in a report with Report 
Manager: 

 
Step Action 

1 In a report, in Report Manager, on the Data tab, under Variables, 
select an object. 

NOTE: To select multiple objects, hold down the Ctrl key. 

2 Drag and drop the object to a block in the report. 
NOTE: Pay attention to the status bar at the bottom of Business 

Objects 5.1.5.  The bar helps you determine how the 
object will be placed when you drop it in different 
locations. 

Continued on next page 
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About Report Manager, Continued 

 
Procedure to 
Remove an 
Object From a 
Report to 
Report 
Manager 

The following table describes how to remove an object from a report to 
Report Manager: 

 

Step Action 

1 In a report, select the data portion of the object you want to 
remove. 

2 Drag and drop it to the Data tab of Report Manager. 

  
Procedure to 
Edit a Query 
From Report 
Manager 

The following table describes how to edit a query from Report Manager: 

 

Step Action 

1 In Report Manager, on the Data tab, right-click in the Variables 
area. 

2 On the menu, click Edit Data Provider. 

3 In the Query Panel - EAS IV Repository Universe window, edit 
the query. 

4 Click Run. 

Continued on next page 
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About Report Manager, Continued 

 
Procedure to 
Create a New 
Query From 
Report 
Manager 

The following table describes how to create a new query from Report 
Manager: 

 

Step Action 

1 In a report, in Report Manager, on the Data tab, right-click in the 
Variables section. 

2 On the menu, click New Data Provider. 

3 In the New Data Wizard, Insert New Data window, do one of the 
following: 

  If Then  

  You want to create a new 
query from the EAS IV 
Repository database 

a) In the To retrieve new 
data, you can section, 
click Build a new query 
on the universe currently 
in use. 

b) Click Finish. 

c) In the Query Panel - 
EAS IV Repository 
Universe window, create a 
query. 

d) Run the query. 

 

  

Continued on next page 
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About Report Manager, Continued 

  
Procedure to Create a New Query From Report Manager (continued) 
 

Step Action 

 

 If Then 

3, cont. 

 You want to access your own 
personal data files from 
programs such as Excel 

a) In the To retrieve new 
data, you can section, 
click Access new data in a 
different way. 

b) Click Begin. 

c) In the New Data Wizard, 
Specify Data Access 
window, click Others. 

d) Verify that Personal Data 
Files is selected in the 
box. 

e) Click Finish. 
f) In the Access Personal 

Data window, retrieve 
your data. 
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LESSON B 
SELECTING CELLS AND BLOCKS 

Overview 

  
Introduction In this lesson, you will learn about the different ways to select cells and 

blocks within a report. 

  
Lesson 
Objectives 

Upon completion of this lesson, you will be able to do the following: 
• Describe the different kinds of cells and blocks in a report 

• Describe the different arrows used for selecting cells and blocks 

  
Order of Topics This lesson includes the following topics: 
 

Topic See Page 

Block and Cell Types 5-14 

Selecting Blocks and Cells 5-15 
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Block and Cell Types 

  
Introduction In this topic, you will learn about the different types of blocks and cells that a 

report may contain. 

  
Description A report may hold up to three different kinds of blocks: A table block, a chart 

block, and a crosstab block.  Blocks consist of cells of data.  Cells also make 
up the supporting data for blocks, such as title cells and free form cells. 

 
 

 
 

 
 

 

  

Title Cell

Free form 
cell with a 
picture 

Table 
block 

Chart 
Block 

Crosstab 
Block 
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Selecting Blocks and Cells 

  
Introduction In this topic, you will learn how to select blocks and cells in a report. 

  
Description There are a variety of different arrows and ways to select blocks and cells in a 

report.  Each different way affects your ability to change the block or cell in a 
particular way.  It is important to pay careful attention to the way you select a 
block or cell.  Practice is the best way to determine all the selections and their 
effects. 

   
 The following diagram displays the various block selections you can make in 

a report: 

Continued on next page 

This rope border 
selects the entire 
block.  Click once 
in a block. 

Charts have 
internal 
borders for 
sizing. Click 
inside the rope 
border and 
then drag from 
the black 
squares. 
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Selecting Blocks and Cells, Continued 

 
 The following table describes the kinds of arrows you may use in a report and 

how to access the arrows: 

 

Symbol Description Procedure 

 
This symbol moves 
vertical lines from left 
to right and right to left. 
It allows you to 
increase and decrease 
the width of columns 
and cell lines. 

Hold the cursor over 
the vertical line you 
want to change until 
this symbol appears. 
Drag the line to its new 
position. 

 
This symbol moves 
horizontal lines from 
top to bottom and 
bottom to top.  It allows 
you to increase and 
decrease the height of 
columns and cell lines. 

Hold the cursor over 
the horizontal line you 
want to change until 
this symbol appears. 
Drag the line to its new 
position. 

 
This arrow selects an 
entire column of data 
including the header 
cell. 

Hold the cursor over 
the top border of the 
column’s header cell. 
When this arrow 
appears, left-click. 

Continued on next page 
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Selecting Blocks and Cells, Continued 

  
Symbol Description Procedure 

 
This arrow allows you 
to select all rows in a 
table or crosstab. 

Hold the cursor over 
the left border of a row. 
When this arrow 
appears, left-click. 

 
This symbol moves 
blocks. 

Click once in a block to 
select the block so that 
the rope border appears. 
Hold the cursor over 
the rope border until 
this symbol appears.  
Drag the block to its 
new position. 

 
This arrow extends the 
size of charts. It may 
appear in various 
positions, diagonal, 
horizontal, and vertical. 

Select a chart so that 
the rope border and the 
internal border appear. 
Hold the cursor over 
the black square on the 
line you want to extend. 
Drag the line to its new 
position. 
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LESSON C 
FORMATTING REPORTS 

Overview 

  
Introduction In this lesson, you will learn how to format reports. 

  
Lesson 
Objectives 

Upon completion of this lesson, you will be able to do the following: 
• Describe the various methods to use when formatting a report 

• Rotate a table 

• Change number format 

• Change text alignment 

• Change borders and shading 

• Move columns 

• Insert blank columns and rows 

• Filter 

• Sort 

• Set breaks 

• Set Master/Detail reports 

  
Order of Topics This lesson includes the following topics: 

 

Topic See Page 

Ways to Format 5-21 

Rotating a Table 5-23 

Changing Number Formatting 5-24 

Changing Text Alignment 5-26 

Changing Font 5-28 

Changing Borders 5-31 

Continued on next page 
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Overview, Continued 

  
Order of Topics (continued) 
 

Topic See Page 

Changing Shading 5-35 

Moving Columns 5-39 

Inserting Blank Columns  5-41 

Inserting Blank Rows 5-43 

Filtering Information 5-45 

Sorting Data 5-47 

Setting Breaks 5-49 

Setting Master/Detail Reports 5-51 
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Ways to Format  

  
Introduction In this topic, you will learn about the various ways to format a report.  In 

many cases, it is possible to use a variety of methods but end with the same 
result.  Sometimes the method you use is a matter of preference, but it can 
also be a matter of choosing the method that is easier or faster. 

  
Description The four basic ways to format a report include using menus, using Report 

Manager, using Slice and Dice, or directly formatting the report.  The 
following table describes each method. 

 
Method Description 

Menus To use menus, you must first select 
the portion of a report you wish to 
format.  Then you click various menu 
items to choose your format.  You 
can only perform one format function 
at a time.  In most cases right-
clicking a selected area offers 
comparable menu choices. 

Report Manager Report Manager allows you limited 
access to certain types of formatting, 
such as the position of objects within 
a report.  Dragging and dropping is 
easily performed; however, you 
cannot perform any detailed 
formatting. 

Continued on next page 
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Ways to Format, Continued 

  
Description (continued) 
 

Method Description 

Slice and Dice Slice and Dice allows for multi-
feature formatting on multiple 
objects within a block and across 
blocks.  This is the most versatile, 
easiest and quickest way to format a 
report. 

Direct report formatting You must select the area of the report 
you wish to format and then right-
click for menu options or use the 
toolbar icons.  This is easy and 
immediate formatting which can be 
applied to one column or data section 
at a time. 
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Rotating a Table 

  
Introduction In this topic, you will learn how to rotate a table.  Rotating a table causes the 

header cells to align left and the data to spread horizontally across the report. 

  
Procedure to 
Rotate a Table 
With the 
Format Menu 

The following table describes how to rotate a table with the Format menu: 

 
Step Action 

1 In a report, select a table. 

2 On the Format menu, click Rotate Table. 
NOTE: You may also right-click and click Rotate Table. 

  
Procedure to 
Rotate a Table 
With the 
Report Toolbar 

The following table describes how to rotate a table using the Report toolbar: 

 

Step Action 

1 In a report, select a table. 

2 On the Report toolbar, click the Rotate Table icon ( ). 

   



EAS IV Repository Functional User’s Guide 
 

May 2003 5-24 105-03-001 

Changing Number Formatting 

  
Introduction In this topic, you will learn how to change number formatting in a report.  

Numbers may erroneously appear out of format, or you may wish to view 
them in a different format.  For example, you can choose how many decimal 
places you want to see in a number. 

  
Procedure to 
Change 
Number 
Formatting 
With the 
Format Menu 

The following table describes how to change number formatting with the 
Format menu: 

 
Step Action 

1 In a report, select the cell(s) that you want to format. 

2 On the Format menu, click Format Cell. 

NOTE: You may also right-click and click Format Cell. 

3 In the Cell Format window, click the Number tab. 

4 In the Category box, select the type of number. 

5 In the Format box, select the style of number. 

6 Click OK. 

Continued on next page 
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Changing Number Formatting, Continued 

  
Procedure to 
Change 
Number 
Formatting 
With the 
Formatting 
Toolbar 

The following table describes how to change number formatting with the 
Formatting toolbar: 

 
Step Action 

1 In a report, select the cell(s) that you want to format. 

2 If you want the data in currency format, on the Formatting toolbar, 

click the Currency Style icon ( ).  

3 If you want the data in percent format, on the Formatting toolbar, 

click the Percentage Style icon ( ). 

4 If you want the data in million format, on the Formatting toolbar, 

click the Million Style icon ( ). 

5 If you want to add a decimal place, on the Formatting toolbar, 
click the Add a Decimal Place icon ( ). 

6 If you want to remove a decimal place, on the Formatting toolbar, 

click the Remove a Decimal Place icon ( ).  
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Changing Text Alignment 

  
Introduction In this topic, you will learn how to change text alignment in a report.  You 

can align text from left to right across a cell as well as up to down in a cell.  
Wrapping text means the text in cells wraps underneath itself instead of 
extending in one line from left to right.  This helps in reducing column width; 
however, you may need to adjust the row height. 

  
Procedure to 
Change Text 
Alignment 
With the 
Format Menu 

The following table describes how to change text alignment with the Format 
menu: 

 
Step Action 

1 In a report, select the cell(s) that you want to format. 

2 On the Format menu, click Format Cell. 
NOTE: You may also right-click and click Format Cell. 

3 In the Cell Format window, click the Alignment tab. 

Continued on next page 
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Changing Text Alignment, Continued 

  
Procedure to Change Text Alignment With the Format Menu (continued) 

 

Step Action 

4 If you want to align horizontally, under Horizontal, select the 
alignment. 

5 If you want to align vertically, under Vertical, select the 
alignment. 

6 If you want to Wrap text, under Settings, select Wrap Text. 

7 Click OK. 

  
Procedure to 
Change Text 
Alignment 
With the 
Formatting 
Toolbar 

The following table describes how to change text alignment with the 
Formatting toolbar: 

 
Step Action 

1 In a report, select the cell(s) that you want to format. 

2 If you want to align the text left, on the Formatting toolbar, click 

the Align Left icon ( ). 

3 If you want to center the text, on the Formatting toolbar, click the 

Center icon ( ). 

4 If you want to align the text right, on the Formatting toolbar, click 
the Align Right icon ( ). 

5 If you want to justify the text, on the Formatting toolbar, click the 

Justify icon ( ). 
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Changing Font 

  
Introduction  In this topic, you will learn how to change the text font in a report. 

  
Procedure to 
Change Font 
With the 
Format Menu 

The following table describes how to change font with the Format menu: 

 
Step Action 

1 In a report, select the cell(s) that you want to format. 

2 On the Format menu, click Format Cell. 

NOTE: You may also right-click and click Format Cell. 

3 In the Cell Format window, click the Font tab. 

4 In the Font box, select a font. 

5 In the Font Style box, select a font style. 

Continued on next page 
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Changing Font, Continued 

  
Procedure to Change Font With the Format Menu (continued) 
 

Step Action 

6 In the Size box, select a font size. 

7 If you want to underline cell text, under Effects, select Underline. 

8 If you want to cross through cell text, under Effects, select 
Strikethrough. 

9 If you want to change the font color, under Color, to the right of 
Custom, click in the color display field. 

10 In the Color window, select a color. 

 
11 Click OK. 

12 In the Cell Format window, click OK. 

Continued on next page 
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Changing Font, Continued 

 
Procedure to 
Change Font 
With the 
Standard 
Toolbar 

The following table describes how to change font with the Standard toolbar: 

  
Step Action 

1 In a report, select the cell(s) that you want to format. 

2 If you want to change font style, on the Standard toolbar, in the 
Font box, click the down arrow ( ). 

3 In the list, select the font style. 

4 If you want to change font size, on the Standard toolbar, in the 

Font Size box, click the down arrow ( ). 

5 In the list, select the font size. 

6 If you want boldface font, on the Standard toolbar, click the bold 

icon ( ). 

7 If you want italicized font, on the Standard toolbar, click the Italic 

icon ( ). 

8 If you want to underline, on the Standard toolbar, click the 

Underline icon ( ). 
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Changing Borders 

  
Introduction In this topic, you will learn how to change border style and color and to 

remove borders of cells in a report. 

  
Procedure to 
Change 
Borders With 
the Formatting 
Menu 

The following table describes how to change borders with the Formatting 
menu: 

 

Step Action 

1 In a report, select the cell(s) you want to format. 

2 On the Format menu, click Format Cell. 

NOTE: You may also right-click and click Format Cell. 

3 Click the Border tab. 

Continued on next page 
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Changing Borders, Continued 

  
Procedure to Change Borders With the Formatting Menu (continued) 
 

Step Action 

4  

  If Then  

  If you do not want any 
borders 

In the Presets section, click 
None. 

 

  If you want four exterior 
borders, or you want to select 
particular borders  

In the Presets section, click 
Box. 

 

  

5 If you want to change the style of the border, under Style, select a 
style. 

6 If you want to select a color or colors for the border, in the Color 
section, to the right of Custom, click in the color display field. 

7 In the Color window, select a color. 

 

Continued on next page 
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Changing Borders, Continued 

  
Procedure to Change Borders With the Formatting menu (continued) 

 

Step Action 

8 Click OK. 

9 In the Border section, click the borderlines that you want to affect 
with the new color and style. 

NOTE: It is possible to have different colors and styles for each 
borderline.  Repeat steps 5 through 9 for each different 
borderline. 

10 In the Cell Format window, click OK. 

  
Procedure to 
Change 
Borders With 
the Borders 
Toolbar 

The following table describes how to change borders with the Borders 
toolbar: 

 

Step Action 

1 In a report, select the cell(s) that you want to format. 

2 If you want to change the borderline style, on the Borders toolbar, 
in the Line Style box, click the down arrow. 

3 In the list, select a line style. 

NOTE: To apply the line style change, you must select the 
borders to which you want to apply this change. 

4 If you want to change a top borderline, on the Borders toolbar, 
click the Top Border icon ( ). 

5 If you want to change a bottom borderline, on the Borders toolbar, 
click the Bottom Border icon ( ).  

Continued on next page 
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Changing Borders, Continued 

  
Procedure to Change Borders With the Borders Toolbar (continued) 
 

Step Action 

6 If you want to change a left borderline, on the Borders toolbar, 
click the Left Border icon ( ). 

7 If you want to change a right borderline, on the Borders toolbar, 

click the Right Border icon ( ).  

8 If you want to change the inside border, on the Borders toolbar, 
click the Inside Border icon ( ). 

9 If you want to change the outside border, on the Borders toolbar, 
click the Outside Border icon ( ). 

10 If you do not want any border(s), on the Borders toolbar, click the 
No Border icon ( ).  
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Changing Shading 

  
Introduction In this topic, you will learn how to change the color of cells in a report.  

Shading refers to the background cell color or the background of the report.  
In the Format Cell window, on the Shading tab, select Foreground to adjust 
cell color in a block, and background to adjust the color behind a block.  
When choosing colors, make sure that the font color and the shading color 
contrast.  If the colors are the same, the data in your report will not be visible.  
If the colors are similar, your report will be difficult to read. 

  
Procedure to 
Change 
Shading With 
the Format 
Menus 

The following table describes how to change shading with the Format menu: 

 
Step Action 

1 Select the cell(s) that you want to format. 

2 On the Format menu, click Format Cell. 
NOTE: You may also right-click and click Cell Format. 

Continued on next page 
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Changing Shading, Continued 

  
Procedure to Change Shading With the Format Menu (continued) 
 

Step Action 

3 In the Cell Format window, click the Shading tab. 

Continued on next page 
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Changing Shading, Continued 

  
Procedure to Change Shading With the Format Menu (continued) 
 

Step Action 

4  

  If Then  

  If you do not want any 
shading 

In the Fill section, select 
None. 

 

  You want shading a) In the Fill section, select 
Custom. 

b) In the Shading box, select 
the amount of shading you 
want. 

 

  

5 If you want to change the background color, in the Background 
Color section, to the right of Custom, click in the color display 
field. 

6 In the Color window, select a color. 

7 Click OK. 

8 If you want to change the color in a cell, in the Cell Format 
window, in the Foreground Color section, to the right of Custom, 
click in the color display field. 

9 In the Color window, select a color. 

10 Click OK. 

11 In the Cell Format window, click OK. 

Continued on next page 
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Changing Shading, Continued 

 
Procedures to 
Change 
Shading With 
the Formatting 
Toolbar 

The following table describes how to change shading with the Formatting 
toolbar: 

 
Step Action 

1 In a report, select the cell(s) that you want to format. 

2 On the Formatting toolbar, click the Background Color icon ( ). 

3 In the Color window, under Basic Colors, click the color you want.

 
4 Click OK. 
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Moving Columns 

  
Introduction In this topic, you will learn how to move the position of columns in a report. 

  
Procedure to 
Move Columns 
in a Report 

The following table describes how to move columns in a report: 

 

Step Action 

1 In a report, select a data cell in the column you want to move. 
NOTE: Do not select the header cell of the column. 

2 Drag and drop the cell to a data cell in a different column. 

  
Procedure to 
Move Columns 
With Slice and 
Dice 

The following table describes how to move columns in Slice and Dice: 

 

Step Action 

1 In a report, click the Slice and Dice icon ( ).  

2 In the Slice and Dice Panel window, in the Block Structure 
section, drag and drop an object to a new position. 

3 Click Apply. 

4 Click the Close Window icon ( ). 

Continued on next page 
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Moving Columns, Continued 

 
Procedure to 
Move Columns 
With the 
Report Manger 

The following table describes how to move columns with Report Manager: 

 

Step Action 

1 If you want to add a column to your report, on the Data tab of 
Report Manager, under Variables, drag and drop an object to the 
report. 

2 If you want to remove a column from your report, select a data cell 
in the column. 

3 Drag and drop the column in Report Manager. 
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Inserting Blank Columns  

  
Introduction In this topic, you will learn how to insert blank columns in a report. 

  
Procedure to 
Insert Blank 
Columns With 
the Insert 
Menu 

The following table describes how to insert blank columns with the Insert 
menu: 

 

Step Action 

1 In a report, in the area that you want to insert a column, select the 
data portion of a column. 

2 On the Insert menu, click Column. 

3 In the Insert a Column window, do one of the following: 

  If Then  

  If you want to insert to the left 
of the selected column 

In the Insert a Column 
window, click Insert a 
Column to the Left of the 
Selection. 

 

  If you want to insert to the 
right of the selected column 

In the Insert a Column 
window, click Insert a 
Column to the Right of the 
Selection. 

 

  

4 Click OK. 

Continued on next page 
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Inserting Blank Columns, Continued 

 
Procedure to 
Insert Blank 
Columns With 
the Structure 
Toolbar 

The following table describes how to insert a blank column with the Structure 
toolbar: 

 

Step Action 

1 In a report, in the area that you want to insert a column, select the 
data portion of a column. 

2 On the Structure toolbar do one of the following: 

  If Then  

  You want to insert to the right 
of the selected column 

Click the Insert Column After 
icon ( ). 

 

  You want to insert to the left 
of the selected column 

Click the Insert Column 
Before icon ( ). 
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Inserting Blank Rows 

  
Introduction In this topic, you will learn how to insert a blank row in a report.  Rows are 

not considered individual entities in a report; therefore, formatting applied to 
one row is applied to all rows. 

  
Procedure to 
Insert a Blank 
Row With the 
Insert Menu 

The following table describes how to insert a blank row with the Insert menu: 

 

Step Action 

1 In a report, select the data portion of a row. 

2 On the Insert menu, click Row. 

3 In the Insert a Row window, do one of the following: 

  If Then  

  If you want to insert a blank 
row above the selected row 

Click Insert a Row Above 
Selection. 

 

  If you want to insert a blank 
row below the selected row 

Click Insert a Row Below 
Selection. 

 

  

4 Click OK. 

Continued on next page 
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Inserting Blank Rows, Continued 

 
Procedure to 
Insert a Blank 
Row With the 
Standard 
Toolbar 

The following table describes how to insert a blank row with the Standard 
toolbar: 

 

Step Action 

1 In a report, select the data portion of a row. 

2 On the Standard toolbar, do one of the following: 

  If Then  

  If you want to insert a blank 
row above the selected row 

Click the Insert Row Above 
icon ( ). 

 

  If you want to insert a blank 
row below the selected row 

Click the Insert Row Below 
icon ( ). 
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Filtering Information 

  
Introduction In this topic, you will learn how to filter information in a report. 

  
Definition Filters temporarily remove data to allow you to focus on select data. 

  
Procedure to 
Insert a Filter 
in a Report 

The following table describes how to insert a filter in a report: 

 

Step Action 

1 In a report, select the data portion of a column. 

2 On the Report toolbar, click the Insert Filter icon ( ). 

3 In the Apply a Filter on <Name of Object> window, select the 
values for which you want to filter the report. 

4 Click OK. 
NOTE: Repeat steps 1 through 4 for each filter you want to 

apply. 

  
Procedure to 
Insert a Filter 
With the Insert 
Menu 

The following table describes how to insert a filter with the Insert menu: 

Step Action 

1 In a report, select the data portion of a column. 

2 On the Insert menu, click Filter. 

3 In the Apply a Filter on <Name of Object> window, select the 
values for which you want to filter the report. 

4 Click OK. 

NOTE: Repeat steps 1 through 4 for each filter you want to 
apply. 

Continued on next page 
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Filtering Information, Continued 

 
Procedure to 
Insert a Filter 
With Slice and 
Dice 

The following table describes how to insert a filter with Slice and Dice: 

 

Step Action 

1 In a report, click the Slice and Dice icon ( ). 

2 In the Slice and Dice Panel window, click the object to which you 
want to apply a filter. 

3 
Click the Apply Filter icon ( ). 

4 In the Apply a Filter on <Name of Object> window, select the 
values for which you want to filter the report. 

5 Click OK. 

NOTE: Repeat steps 1 through 5 for each filter you want to 
apply. 

6 Click Apply. 

7 Click the Close Window icon ( ). 
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Sorting Data 

  
Introduction In this topic, you will learn how to sort data in a report. 

  
Definition A sort orders data in a specific manner, either ascending (the default) or 

descending.  Sorts are applied in the order in which you define them, and the 
sorts are numbered to show you the order. 

  
Procedure to 
Apply a Sort 
With the 
Report Toolbar 

The following table describes how to apply a sort with the Report toolbar: 

 

Step Action 

1 In a report, select the data portion of a column that you wish to 
sort. 

2 If you want an Ascending sort, on the Report toolbar, click the 

Sorts icon ( ). 

3 If you want a descending sort, on the Report toolbar, click the 

down arrow on the Insert Sort icon ( ). 

4 Click the Apply Descending Sort icon ( ). 

Continued on next page 
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Sorting Data, Continued 

 
Procedure to 
Apply a Sort 
With the Insert 
Menu 

The following table describes how to apply a sort with the Insert menu: 

 

Step Action 

1 In a report, select the data portion of a column that you wish to 
sort. 

2 If you want to apply an ascending sort, on the Insert menu, point to 
Sort, and then click Ascending. 

3 If you want to apply a descending sort, on the Insert menu, point to 
Sort, and then click Descending. 

  
Procedure to 
Apply a Sort 
With Slice and 
Dice 

The following table describes how to apply a sort with Slice and Dice: 

 
Step Action 

1 In a report, click the Slice and Dice icon ( ). 

2 In the Slice and Dice Panel window, select the object to which you 
want to apply a sort. 

3 Click the Apply Sort icon ( ). 

4 If you want to change from ascending to descending, double-click 

the sort icon ( ) on the object. 

5 Click Apply. 

6 Click the Close Window icon ( ). 
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Setting Breaks 

  
Introduction In this topic, you will learn how to set breaks in a report.  By applying breaks, 

you can organize your report into meaningful sections, which group similar 
data items together with a break before the next group of data.  As with sorts, 
when you apply breaks to more than one object, the breaks are numbered to 
show you the order in which the breaks are applied. 

  
Procedure to 
Apply Breaks 
With the Insert 
Menu 

The following table describes how to apply a break with the Insert menu: 

 

Step Action 

1 In a report, select the data portion of a column to which you want 
to apply a break. 

2 On the Insert menu, click Break. 

  
Procedure to 
Apply a Break 
With the 
Report Toolbar 

The following table describes how to apply a break with the Report toolbar: 

 
Step Action 

1 In a report, select the data portion of a column to which you want 
to apply a break. 

2 On the Report toolbar, click the Insert Break icon ( ). 

Continued on next page 
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Setting Breaks, Continued 

 
Procedure to 
Apply a Break 
With Slice and 
Dice 

The following table describes how to apply a break with Slice and Dice: 

 

Step Action 

1 In a report, click the Slice and Dice icon ( ). 

2 In the Slice and Dice Panel window, select the object to which you 
want to apply a break. 

3 Click the Apply Break icon ( ). 

4 Click Apply. 

5 Click the Close Window icon ( ). 
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Setting Master/Detail Reports 

  
Introduction In this topic, you will learn how to set master/detail reports. 

  
Description If many or all of the cells in a column hold identical data, you may want to set 

the column’s object as a master.  When you set an object as master, the report 
is broken into sections corresponding to the values of the master object.  The 
column corresponding to the master object disappears, and the value of the 
master object appears as a heading at the beginning of each section of 
corresponding detail data.  However, in Slice and Dice you have the option to 
keep the data column as part of the report as well as make it a master cell. 

  
Procedure to 
Set 
Master/Detail 
Reports With 
the Report 
Toolbar 

The following table describes how to set master/detail reports with the Report 
toolbar: 

 

Step Action 

1 In a report, select the data portion of a column that you want to set 
as master. 

2 On the Report toolbar, click the Set as Master icon ( ). 

  
Procedure to 
Set 
Master/Detail 
Reports With 
the Format 
Menu 

The following table describes how to set master/detail reports with the Format 
menu: 

 
Step Action 

1 In a report, select the data portion of a column that you want to set 
as master. 

2 On the Format menu, click Set as Master. 

Continued on next page 



EAS IV Repository Functional User’s Guide 
 

May 2003 5-52 105-03-001 

Setting Master/Detail Reports, Continued 

 
Procedure to 
Set 
Master/Detail 
in a Report 

The following table describes how to set master/detail in a report: 

 

Step Action 

1 In a report, select the data portion of a column that you want to set 
as master. 

2 Drag and drop outside of the block. 

  
Procedure to 
Set 
Master/Detail 
With Report 
Manager 

The following table describes how to set master/detail with Report Manager: 

 

Step Action 

1 In Report Manager, on the Data tab, in the Variables section, drag 
an object to the report. 

NOTE: You must have at least one column in the report. 

Continued on next page 
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Setting Master/Detail Reports, Continued 

  
Procedure to 
Set 
Master/Detail 
with Slice and 
Dice 

The following table describes how to set master/detail with Slice and Dice. 

 
Step Action 

1 In a report, click the Slice and Dice icon ( ). 
2 In the Slice and Dice Panel window, click the Show/Hide Section 

icon ( ). 
3 If you want the master cell to be separated from the block, in the 

Block Structure section, drag the object you want for master to the 
Section section. 

Continued on next page 
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Setting Master/Detail Reports, Continued 

  
Procedure to Set Master/Detail with Slice and Dice (continued) 
 

Step Action 
4 If you want the master cell to remain as part of the block, in the 

Available Variables section, under Variables, drag the object you 
want for master to the Section section. 
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UNIT 6 
ANALYZING DATA 

Overview 

  
Introduction In this unit, you will learn how to use a variety of analysis tools to better 

interpret data results in reports. 

  
Unit Objectives Upon completion of this unit, you will be able to do the following: 

• Apply simple analysis tools 

• Apply complex analysis tools 

  
In This Unit This unit includes the following lessons: 
 

Lesson See Page 

Lesson A:  Simple Analysis Tools 6-3 

Lesson B:  Complex Analysis Tools 6-15 
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LESSON A 
SIMPLE ANALYSIS TOOLS 

Overview 

  
Introduction In this lesson, you will learn how to apply simple analysis tools, such as 

calculations and rankings. 

  
Lesson 
Objectives 

Upon completion of this lesson you will be able to do the following: 
• Apply Calculations 

• Apply Rankings 

  
Order of Topics This lesson includes the following topics: 
 

Topic See Page 

Applying Calculations 6-4 

Applying Rankings 6-8 
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Applying Calculations 

  
Introduction In this topic, you will learn how to apply various types of calculations to data 

in a report. 

  
Description The following table describes the various simple calculations you can perform 

in a report: 

 

Calculation Description 

Sum Adds all the values in the selected 
area of the report 

Count Counts the number of occurrences 
for the values in the selected area of 
the report; based on the distinct 
occurrence of a value 

Count All Counts all occurrences for a value in 
the selected area of a report; based on 
any occurrence for a value, whether 
it is duplicate information or even if 
there are no data in a row 

Average Calculates the average of all the 
values in the selected area of the 
report 

Minimum Determines the smallest value of all 
the values in the selected area of the 
report 

Maximum Determines the largest value of all 
the values in the selected area of the 
report 

Percentage Calculates and inserts a column with 
the percentage of all the values in the 
selected area of the report  

Continued on next page 
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Applying Calculations, Continued 

 
Procedure to 
Apply 
Calculations 
With the Data 
Menu 

The following table describes how to apply calculations with the Data menu: 

 

Step Action 

1 In a report, select the data portion of the column to which you 
want to apply a calculation. 

2 On the Data menu, point to Calculations, and then click the type of 
calculation you want. 

  
Procedure to 
Apply 
Calculations 
With the 
Report Toolbar 

The following table describes how to apply calculations with the Report 
toolbar: 

 
Step Action 

1 In a report, select the data portion of the column to which you 
want to apply a calculation. 

2 If you want a sum, on the Report toolbar, click the Insert Sum icon 
( ). 

3 If you want a percentage, on the Report toolbar, click the Insert 
Percentage icon ( ). 

4 If you want a count, on the Report toolbar, click the Insert Count 
icon ( ). 

Continued on next page 
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Applying Calculations, Continued 

 
Procedure to 
Apply 
Calculations 
With Slice and 
Dice 

The following table describes how to apply calculations with Slice and Dice: 

 

Step Action 

1 In a report, click the Slice and Dice icon ( ). 

2 In the Slice and Dice Panel window, select the object to which you 
want to apply a calculation. 

3 Click the Insert Calculation icon ( ). 

4 If you want to specify which kind(s) of calculations to apply to the 
object, double-click the Calculation icon. 

Continued on next page 
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Applying Calculations, Continued 

  
Procedure to Apply Calculations With Slice and Dice (continued) 
 

Step Action 

5 In the Calculations window, under Functions, select the 
calculations that you want to apply. 

 
6 Click OK. 

7 In the Slice and Dice Panel window, click Apply. 

8 Click the Close Window icon ( ). 
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Applying Rankings 

  
Introduction In this topic, you will learn how to apply rankings to data in a report. 

  
Definition A ranking acts as a filter but is applicable to extreme ranges of data such as 

the highest and lowest numbers of a category. 

  
Description A simple sort ranks data from highest to lowest or vice versa.  However, a 

rank also enables you to specify a portion of the data you want ranked, such 
as a particular top or bottom amount.  For example, you could rank based on 
the top 10 highest salary expenses. 

  
Procedure to 
Apply a 
Ranking With 
the Format 
Menu 

The following table describes how to apply a ranking with the Format menu: 

 
Step Action 

1 In a report, select the data portion of a column based on a 
dimension object. 

2 On the Format menu, click Ranking. 

Continued on next page 
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Applying Rankings, Continued 

  
Procedure to Apply a Ranking With the Format Menu (continued) 
 

Step Action 

3 In the Select Top/Bottom for <Object Name> window, under 
Selection, in the Based On box, click the down arrow. 

 
4 In the list, select the measure object whose values you want to 

rank. 

Continued on next page 
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Applying Rankings, Continued 

  
Procedure to Apply a Ranking With the Format Menu (continued) 

 

Step Action 

5  

  If Then  

  If you want to base the 
ranking on high values 

a) Under Selection, select 
Top. 

b) Under Top, type a 
number. 

 

  If you want to base the 
ranking on low values 

a) Under Selection, select 
Bottom. 

b) To the right of Bottom, 
type a number. 

 

  If you want both high and low 
values 

a) Under Selection, select 
Top. 

b) To the right of Top, type a 
number. 

c) Select Bottom. 
d) To the right of Bottom, 

type a number. 

 

  

6 If you want the ranking to display subtotals, under Calculations, 
select Display Subtotals. 

7 If you want the ranking to display percentages, under Calculations, 
select Display Percentages. 

8 Click OK. 

Continued on next page 
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Applying Rankings, Continued 

 
Procedure to 
Apply Ranking 
With the 
Report Toolbar 

The following table describes how to apply a ranking with the Report toolbar: 

 

Step Action 

1 In a report, select the data portion of a column based on a 
dimension object. 

2 On the Report toolbar, click the Apply Ranking icon ( ). 

3 In the Select Top/Bottom for <Object Name> window, under 
Selection, in the Based On box, click the down arrow. 

4 In the list, select the measure object whose values you want to 
rank. 

Continued on next page 
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Applying Rankings, Continued 

  
Procedure to Apply Ranking With the Report Toolbar (continued) 
 

Step Action 

5  

  If Then  

  If you want to base the 
ranking on high values 

a) Under Selection, select 
Top. 

b) To the right of Top, type a 
number. 

 

  If you want to base the 
ranking on low values 

a) Under Selection, select 
Bottom. 

b) To the right of Bottom, 
type a number. 

 

  If you want both high and low 
values 

a) Under Selection, select 
Top. 

b) To the right of Top, type a 
number. 

c) Select Bottom. 
d) To the right of Bottom, 

type a number. 

 

  

6 If you want the ranking to display subtotals, under Calculations, 
select Display Subtotals. 

7 If you want the ranking to display percentages, under Calculations, 
select Display Percentages. 

8 Click OK. 

Continued on next page 
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Applying Rankings, Continued 

 
Procedure to 
Apply a 
Ranking With 
Slice and Dice 

The following table describes how to apply a ranking with Slice and Dice: 

 

Step Action 

1 In a report, click the Slice and Dice icon ( ). 

2 In the Slice and Dice Panel window, select the dimension object to 
which you want to apply a ranking. 

3 
Click the Apply Ranking icon ( ). 

4 In the Select Top/Bottom for <Object Name> window, under 
Selection, in the Based On box, click the down arrow. 

5 In the list, select the measure object whose values you want to rank. 

Continued on next page 
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Applying Rankings, Continued 

  
Procedure to Apply a Ranking With Slice and Dice (continued) 
 

Step Action 

6  

  If Then  

  If you want to base the 
ranking on high values 

a) Under Selection, select 
Top. 

b) To the right of Top, type a 
number. 

 

  If you want to base the 
ranking on low values 

a) Under Selection, select 
Bottom. 

b) To the right of Bottom, 
type a number. 

 

  If you want both high and low 
values 

a) Under Selection, select 
Top. 

b) To the right of Top, type a 
number. 

c) Select Bottom. 
d) To the right of Bottom, 

type a number. 

 

  

7 If you want the ranking to display subtotals, under Calculations, 
select Display Subtotals. 

8 If you want the ranking to display percentages, under Calculations, 
select Display Percentages. 

9 Click OK. 

10 In the Slice and Dice Panel window, click Apply. 

11 Click the Close Window icon ( ). 
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LESSON B 
COMPLEX ANALYSIS TOOLS 

Overview 

  
Introduction In this lesson, you will learn how to apply complex analysis tools, such as 

variables and alerters, to data in a report. 

  
Lesson 
Objectives 

Upon completion of this lesson, you will be able to do the following: 
• Create Variables 

• Create Alerters 

• Drill through layers of data 

  
Order of Topics This lesson includes the following topics: 

 

Topic See Page 

Creating New Variables 6-16 

Creating Alerters 6-22 

Drilling Down 6-28 

Drilling Up 6-31 

Drilling Through 6-32 
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Creating New Variables 

  
Introduction In this topic, you will learn how to create new variables and insert them in a 

report. 

  
Definition Variables are objects you create based on a formula, which combines other 

predefined objects from the database.  For example, you might create a 
variable to show the difference between expenses and obligations, or a 
variable to show average daily patient load. 

  
Procedure to 
Insert a 
Variable With 
the Data Menu 

The following table describes how to insert a variable with the Data menu: 

 

Step Action 

1 In a report, insert a blank column. 

2 Select the data portion of the blank column. 

3 On the Data menu, click Variables. 

NOTE: You may also right-click and click Variables. 

Continued on next page 
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Creating New Variables, Continued 

  
Procedure to Insert a Variable With the Data Menu (continued) 
 

Step Action 

4 In the Variables window, click Add. 
 

 

Continued on next page 
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Creating New Variables, Continued 

  
Procedure to Insert a Variable With the Data Menu (continued) 
 

Step Action 

5 In the Variable Editor window, click the Definition tab. 

6 In the Name box, type the name of the variable. 

7 Under Qualification, select the type of variable. 

Continued on next page 
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Creating New Variables, Continued 

  
Procedure to Insert a Variable With the Data Menu (continued) 
 

Step Action 

8 Click the Formula tab. 

9 In the Formulas box, create the formula for the variable. 
NOTE: You may do this by typing the formula or by double-

clicking in the Operators, Functions, and Variables 
sections.  All variables must start with the equal sign. 

Continued on next page 
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Creating New Variables, Continued 

  
Procedure to Insert a Variable With the Data Menu (continued) 
 

Step  Action 

10 Click OK. 

11 In the Variables window, click Insert. 

 

Continued on next page 
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Creating New Variables, Continued 

 
Procedure to 
Insert a 
Variable With 
Report 
Manager 

The following table describes how to insert a variable with Report Manager: 

 
Step Action 

1 In a report, insert a blank column. 

2 Select the data portion of the blank column. 

3 In Report Manager, on the Data tab, right-click Variables. 

4 On the menu, click New Variable. 

5 In the Variables window, click Add. 

6 In the Variable Editor window, click the Definition tab. 

7 In the Name box, type the name of the variable. 

8 Under Qualification, select the type of variable. 

9 Click the Formula tab. 

10 In the Formula box, create the formula for the variable. 
NOTE: You may do this by typing the formula or by double-

clicking in the Operators, Functions, and Variables 
sections.  All variables must start with the equal sign. 

11 Click OK. 

12 In the Variables window, click Insert. 
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Creating Alerters 

  
Introduction In this topic, you will learn how to create an Alerter and insert it into a report. 

  
Definition An alerter is a combination of criteria that you set up to draw attention to data 

that meet certain requirements by highlighting text or overwriting the text 
with a message of your choice. 

  
Procedure to 
Create Alerters 
With the 
Format Menu 
and the Report 
Toolbar 

The following table describes how to create alerters with the Format menu 
and the Report toolbar: 

 

Step Action 

1 Select the data portion of a report to which you want to apply an 
alerter. 

2 On the Format menu, click Alerters. 

NOTE: You may also click the Alerters icon ( ) on the Report 
toolbar. 

Continued on next page 
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Creating Alerters, Continued 

  
Procedure to Create Alerters With the Format Menu and the Report Toolbar (continued) 
 

Step Action 

3 In the Alerters window, click Add. 

 

Continued on next page 
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Creating Alerters, Continued 

  
Procedure to Create Alerters With the Format Menu and the Report Toolbar (continued) 

 

Step Action 

4 In the Edit Alerters window, click the Definition tab. 
 

5 In the Name box, type the name of the alerter. 

6 If you want to add details about the alerter, in the Description box, 
type the description. 

7 Click the Conditions tab. 

Continued on next page 
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Creating Alerters, Continued 

  
Procedure to Create Alerters With the Format Menu and the Report Toolbar (continued) 
 

Step Action 

8 In the Variable to Compare box, select the object upon which you 
want to base the alerter. 

9 In the Operator 1 box, select the operator. 

Continued on next page 
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Creating Alerters, Continued 

  
Procedure to Create Alerters With the Format Menu and the Report Toolbar (continued) 
 

Step Action 

10 In the Value 1 box, do one of the following: 

  If Then  

  You want to select a value 
from the list 

a) Click the down arrow. 
b) Click List of Values. 
c) In the List of Values for 

<Name of Object> 
window, select the value. 

d) Click OK. 

 

  You want to type a value Type the value. 
NOTE: For measure 

objects, do not use 
decimals or 
commas when 
typing; doing so 
produces an error. 

 

  You want to select a variable 
for the value 

a) Click the down arrow. 

b) Click Variables. 
c) In the Variables window, 

select the variable. 

d) Click Insert. 

 

  

11 Repeat steps 9 and 10 to select a second operator and value. 

NOTE: It is possible to have 5 different alerter condition 
statements with 10 operators.  If you do not want a 
second operator and value, you must select None on the 
second operator menu. 

Continued on next page 
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Creating Alerters, Continued 

  
Procedure to Create Alerters With the Format Menu and the Report Toolbar (continued) 
 

Step Action 

12  

  If Then  

  You want to change the 
format of the alerter 

a) Click Format. 
b) Follow the instructions in 

Unit 5 to format the 
alerter cell(s). 

 

  You want to enter text for the 
alerter 

a) Click Text. 
b) In the Enter Your Text 

window, enter the text. 

c) Click OK. 

NOTE: This text overwrites 
the value in the cell 
with the text you 
type. 

 

  

13 In the Edit Alerters window, click OK. 

14 In the Alerters window, click OK. 

   



EAS IV Repository Functional User’s Guide 
 

May 2003 6-28 105-03-001 

Drilling Down 

  
Introduction In this topic, you will learn how to drill down through data.  

   
Description Drilling is a tool that enables you to view your data from different 

perspectives in order to analyze the data better.  Drilling only works on 
dimension objects, but any related measure objects aggregate with each drill 
level.  The EAS IV Repository classes are set up so that the objects in them 
are hierarchically arranged, which is important for drilling.  When you drill 
down you go from the highest point of data to its lowest related point.  
Drilling back up takes you in the opposite direction, from the many to the 
singular points of data.  Drilling through enables you to add dimension 
objects to your report to increase the depth of your drill.   

To prepare for drilling in a report, you must set up a Scope of Analysis in the 
Query Panel. 

  
Procedure The following table describes how to drill down in a report: 
 

Step Action 

1 In the Query Panel – EAS IV Repository Universe window, create 
a query with result objects and/or conditions. 

2 On the toolbar, in the Default Scope of Analysis box, click the 
down arrow. 

3 Select the level of drilling that you want. 

4 On the toolbar, click the Scope of Analysis icon ( ). 

Continued on next page 
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Drilling Down, Continued 

  
Procedure (continued) 
 

Step Action 

5 In the Scope of Analysis window, click select by Class. 

 
6 Select any other dimension objects that you want to include in the 

drill. 

7 Click OK. 

8 Run the query. 

Continued on next page 
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Drilling Down, Continued 

  
Procedure (continued) 
 

Step Action 

9 In the report, on the Analysis menu, click Drill. 

NOTE: You may also click the Drill icon ( ) on the Standard 
toolbar. 

10 Right-click the data section of a column. 

11 On the menu, click Drill down. 
NOTE: To continue analysis, repeat steps 10 and 11 until you 

can not drill down further. 
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Drilling Up 

  
Introduction In this topic, you will learn how to drill up through data. 

   
Description Drilling up enables you to return up the hierarchical analysis, going from the 

lower details to the highest one. 

  
Procedure The following table describes how to drill up in a report: 
 

Step Action 

1 In a report, in the data column you drilled down, right-click. 

2 On the menu, click Drill up. 
NOTE: To complete the return to the top of the hierarchy, repeat 

steps 1 and 2 until you cannot drill up further. 
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Drilling Through 

  
Introduction In this topic, you will learn how to drill through data in a report. 

   
Description Drilling through enables you to add more data for your drill than that for 

which you originally allowed in your Scope of Analysis. 

  
Procedure The following table describes how to drill through in a report: 
 

Step Action 

1 In a report using drill, right-click a data column. 

2 On the menu, click Drill Through. 

3 In the Drill Through window, select other dimension objects that 
you want to add to the drill. 

4 Click OK. 
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UNIT 7 
CHARTS AND CROSSTABS 

Overview 

  
Introduction In this unit, you will learn about charts and crosstabs. 

  
Unit Objectives Upon completion of this unit, you will be able to do the following: 

• Work with charts in reports 

• Work with crosstabs in reports 

  
In this Unit This unit includes the following lessons: 

 

Lesson See Page 

Lesson A:  Charts 7-3 

Lesson B:  Crosstabs 7-9 
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LESSON A 
CHARTS 

Overview 

  
Introduction In this lesson, you will learn about charts. 

  
Lesson 
Objectives 

Upon completion of this lesson, you will be able to do the following: 
• Turn a table into a chart 

• Insert a chart in a report 

• Edit a chart 

  
Order of Topics This lesson includes the following topics: 
 

Topic See Page 

Turning a Table Into a Chart 7-4 

Inserting a Chart in a report 7-5 

Editing a Chart 7-8 
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Turning a Table Into a Chart 

  
Introduction In this topic, you will learn how to turn a table into a chart.  Business Objects 

5.1.5 automatically formats the data from a table when you turn it into a chart.  
You can also reverse the process and turn a chart into a table. 

  
Procedure  The following table describes how to turn a table into a chart: 
 

Step Action 

1 In a report, select a table block. 

2 On the Format menu, click Turn to Chart. 
NOTE: You may also right-click and click Turn to Chart. 

3 If you want to select a style other than the default, in the Chart 
AutoFormat window, in the Chart Types list, select a chart. 

4 Under Styles for the Selected Chart Type, select a style. 

5 Click OK. 
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Inserting a Chart in a Report 

  
Introduction In this topic, you will learn how to insert a chart in a report. 

  
Procedure  The following table describes how to insert a chart in a report: 
 

Step Action 

1 In a report, on the Insert menu, click Chart. 

NOTE: You may also click the Insert Chart icon ( ) on the 
Report toolbar. 

2 In a clear area in the report, drag out a medium-sized area. 

3 In the New Chart Wizard, Insert a New Chart window, do one of 
the following: 

Continued on next page 
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Inserting a Chart in a Report, Continued 

  
Procedure (continued) 
 

Step  Action 

 

 If Then  
3, cont. 

 You want to create a chart 
based on the same query or 
one of the queries in the 
existing report 

a) Click Use existing data 
from the document. 

b) Click Begin. 

c) In the second New Chart 
Wizard, Insert a New 
Chart window, in the 
Select the Variables list, 
select the variables you 
want in the chart. 

d) Click Next. 
e) In the Chart AutoFormat 

window, in the Chart 
Types list, select a chart. 

f) Under Styles for the 
selected chart type, select 
a style. 

g) Click Finish. 

 

  

Continued on next page 
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Inserting a Chart in a Report, Continued 

  
Procedure (continued) 
 

Step Action 

 If Then  3, cont. 

 You want to create a chart 
based on a new query  

a) Click Build a new query 
on the universe currently 
in use. 

b) Click Finish. 

c) Create the query. 
d) Run the query. 

 

  You want to create a chart 
based on stored data such as 
an Excel report 

a) Click Access new data in 
a different way. 

b) In the New Chart Wizard, 
Specify Data Access 
window, click Others. 

c) Click the down arrow. 

d)  In the list, select Personal 
data files. 

e) Click Finish. 
f) In the Access Personal 

Data window, retrieve the 
data. 
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Editing a Chart 

  
Introduction In this topic, you will learn how to edit charts. 

  
Description It is possible to make multiple changes to a chart after you create it.  Some of 

these changes include modifying the chart type and style, adding legends, 
changing the borders and shading, and adding and removing objects. 

  
Procedure The following table describes how to edit a chart: 
 

Step Action 

1 In a report, select the chart you want to edit. 

2 On the Format menu, click Edit Chart. 

NOTE: You may also click the Format Block icon ( ). 
 

3 In the Chart Format window, make your changes. 

 
4 Click OK. 
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LESSON B 
CROSSTABS 

Overview 

  
Introduction In this topic, you will learn about crosstabs. 

  
Lesson 
Objectives 

Upon completion of this lesson, you will be able to do the following: 
• Change a table into a crosstab 

• Insert a crosstab 

• Edit a crosstab 

  
Order of Topics This lesson includes the following topics: 
 

Topic See Page 

Changing a Table Into a Crosstab 7-10 

Inserting a Crosstab 7-11 

Editing a Crosstab 7-14 
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Changing a Table Into a Crosstab 

  
Introduction In this topic, you will learn how to change a table into a crosstab. 

   
Description A crosstab is made up of three main parts: The left columns, the body, and the 

header row. 

 
Procedure to 
Turn a Table 
Into a Crosstab 

The following table describes how to turn a table into a crosstab: 

 

Step Action 

1 In a report, select the data portion of a dimension object column. 

2 Drag and drop to the header level of the next column. 

NOTE: When the cursor turns into a crosshair you should drop 
the object. 

  
Procedure to 
Turn a Table 
Into a Crosstab 
With Slice and 
Dice 

The following table describes how to turn a table into a crosstab with Slice 
and Dice: 

 
Step Action 

1 In a report, click the Slice and Dice icon ( ). 

2 In the Slice and Dice Panel window, in the Block Structure 
section, drag a dimension object above the dotted line. 

NOTE: When the cursor turns into a crosshair you should drop 
the object. 

3 Click Apply. 

4 Click the Close Window icon ( ). 
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Inserting a Crosstab 

  
Introduction In this topic, you will learn how to insert a crosstab in a report. 

  
Procedure The following table describes how to insert a crosstab into a report: 
 

Step Action 

1 On the Insert menu, click Crosstab. 

NOTE: You may also click the Insert Crosstab icon ( ).  The 
crosstab symbol with crosshairs above it appears. 

2 In a clear area in the report, drag out a medium-sized area. 

3 In the New Crosstab Wizard, Insert a New Crosstab window, do 
one of the following: 

  

Continued on next page 
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Inserting a Crosstab, Continued 

  
Procedure (continued) 
 

Step Action 

 

 If Then  

3, cont. 

 You want to create a crosstab 
based on the same query or on 
one of the queries in the 
existing report 

a) Click Use existing data 
from document. 

b) Click Begin. 

c) In the second New 
Crosstab Wizard, Insert a 
Crosstab window, in the 
Variables list, select the 
variables you want in the 
crosstab. 

NOTE: You must choose at 
least three 
variables. 

d) Click Next. 

e) In the New Crosstab 
Wizard, Pivot Data for the 
Crosstab window, drag at 
least one variable to each 
folder. 

f) Click Finish. 

 

    

Continued on next page 
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Inserting a Crosstab, Continued 

  
Procedure (continued) 
 

Step Action 
 

 If Then 
3, cont. 

 You want to create a crosstab 
based on a new query 

a)  Click Build a new query 
on the universe currently 
in use. 

 
b) Click Finish. 

 

  You want to create a crosstab 
based on stored data such as 
an Excel report 

a) Click Access new data in 
a different way. 

 
b) In the New Crosstab 

Wizard, Specify Data 
Access window, click 
Others. 

 
c) Click the down arrow. 
 
d)  In the list, select Personal 

data files. 
 
e) Click Finish. 
 
f) In the Access Personal 

Data window, retrieve the 
data. 
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Editing a Crosstab 

  
Introduction In this topic, you will learn how to edit a crosstab. 

  
Procedure The following table describes how to edit a crosstab: 
 

Step Action 

1 In a report, select the crosstab. 

2 On the Format menu, click Crosstab. 

NOTE: You may also click the Format Block icon ( ). 

3 In the Crosstab Format window, make your edits. 

4 Click OK. 
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UNIT 8 
TEMPLATES 

Overview 

  
Introduction In this unit, you will learn about templates. 

  
Unit Objective Upon completion of this unit, you will be able to work with templates. 

  
In This Unit This unit includes the following lesson: 

 

Lesson See Page 

Lesson A:  Templates 8-3 
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LESSON A 
TEMPLATES 

Overview 

  
Introduction In this lesson, you will learn about templates.  You can create your own 

template or change the standard template style. 

  
Lesson 
Objectives 

Upon completion of this lesson, you will be able to do the following: 
• Save a template to the available templates list 

• Apply a template to a report 

• Modify the standard report style 

  
Order of Topics This lesson includes the following topics: 

 

Topic See Page 

Saving a Template 8-4 

Applying a Template 8-5 

Modifying the Standard Report Style 8-6 
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Saving a Template 

  
Introduction In this topic, you will learn how to save a template.  You can create a report 

style that you may wish to use again.  To do so, you save the template.  Then 
you can start new reports in the template format. 

  
Procedure The following table describes how to save a template: 
 

Step Action 

1 In the report you want to use as a template, on the File menu, click 
Save As. 

2 In the Save As window, in the File name box, type a file name. 

3 In the Save as type box, select Business Objects Templates (*.ret). 

 
4 Click Save. 

  



EAS IV Repository Functional User’s Guide 
 

May 2003 8-5 105-03-001 

Applying a Template 

  
Introduction In this topic, you will learn how to apply a template to a report.  Applying a 

template means that you can change the format of a report to that of the 
template you select. 

  
Procedure The following table describes how to apply a template to a report: 
 

Step Action 

1 In a report, on the Format menu, point to Report, and then click 
Apply Template. 

2 In the Apply a Template, Select a Template window, select the 
template you want. 

3 Click OK. 
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Modifying the Standard Report Style 

  
Introduction In this topic, you will learn how to change the standard report style. 

  
Procedure The following table describes how to change the standard report style. 
 

Step Action 

1 In a report, on the Tools menu, click Standard Report Styles. 

2 In the Standard Report Styles window, under Report Components, 
click the plus icon (+) next to the block style you want to format. 
 

3 Make your modifications. 

Continued on next page 
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Modifying the Standard Report Style, Continued 

  
Procedure (continued) 
 

Step Action 
4 Under Report Components, in the list, click the plus icon (+) next 

the block that you want to change. 
 

5 Select the section of the block you want to change. 

6 Make your modifications. 

7 Click OK. 
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UNIT 9 
SENDING DOCUMENTS 

Overview 

  
Introduction In this unit, you will learn about sending reports to other applications and how 

to use the Broadcast Agent. 

  
Unit Objectives Upon completion of this unit, you will be able to do the following: 

• Describe the various ways to send reports 

• Send reports to other applications 

• Use Document Exchange 

  
In This Unit This unit includes the following lessons: 
 

Lesson See Page 

Lesson A:  About Sending Reports 9-3 

Lesson B:  Exporting a Report to an Application 9-7 

Lesson C:  Using Document Exchange 9-11 
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LESSON A 
ABOUT SENDING REPORTS 

Overview 

  
Introduction In this lesson, you will learn about sending reports to other applications and 

about using Document Exchange, which enables you to send documents to 
other users, to corporate documents, or to schedule documents to be sent. 

  
Lesson 
Objectives 

Upon completion of this lesson, you will be able to do the following: 
• Describe sending reports to other applications 

• Describe using Document Exchange 

  
Order of Topics This lesson includes the following topics: 

 

Topic See Page 

Sending Reports to Applications 9-4 

Sending Documents by Document Exchange 9-5 
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Sending Reports to Applications 

  
Introduction In this topic, you will learn about sending reports to other applications. 

  
Description Business Objects 5.1.5 enables you to export reports to applications such as 

Word or Excel.  This is helpful if, for example, you need to send data that you 
gathered from the EAS IV Repository to someone who does not have 
Business Objects software.  It is important to note that Business Objects only 
sends one query and one report per query at a time.  You have to export each 
report per document individually.  Also, most formatting is lost in the 
transfer. 

There are two different ways to send reports to other applications, by the 
simple copy and paste method, or by a more complex Data Manager export 
method.  Both end with similar results. 
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Sending Documents by Document Exchange 

  
Introduction In this topic, you will learn about sending documents by Document 

Exchange. 

  
Description Document Exchange enables Business Objects users to publish documents to 

a server, to place users in user groups, or to schedule document transmissions.  
For example, if one Service member is responsible for creating salary expense 
reports for other Service members at several sites, those reports could be 
published with Document Exchange.  They might be sent to Corporate 
Documents, where all Business Objects EAS IV Repository users could 
access them, or they might go only to users in a particular user group. 

In addition, Document Exchange has a feature called Broadcast Agent, which 
automatically schedules and publishes your document at the time you specify.  
This means you could send a document once or you could send it on a regular 
basis, refreshed, and to a specific user group.  For example, if you have to 
send out the same report every Friday morning, Broadcast Agent will do it for 
you. 
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LESSON B 
EXPORTING A REPORT TO AN APPLICATION 

Overview 

  
Introduction In this topic, you will learn how to export a document to other applications. 

  
Lesson 
Objectives 

Upon completion of this lesson, you will be able to do the following: 
• Export a report through Data Manager 

• Copy and paste a report into another application 

  
Order of Topics This lesson includes the following topics: 

 

Topic See Page 

Exporting a Report  9-8 

Copying a Report to Another Application 9-10 
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Exporting a Report 

  
Introduction In this topic, you will learn how to export a report to another application. 

  
Procedure The following table describes how to export a report to another application: 
 

Step Action 
1 In the report, on the Data menu, click View Data. 

NOTE: You may also click the View Data icon ( ). 

2 In the Data Manager window, under Data Providers, select the 
query that you want to export. 

NOTE: It is important that you renamed the query in order to 
export and save the data correctly.  See Using the Data 
Manager Through the Query Panel in section 4. 

3 On the Results tab, click Export. 

Continued on next page 
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Exporting a Report, Continued 

  
Procedure (continued) 
 

Step Action 

4 In the Export to External Format window, under Format, in the 
Format box, click the down arrow. 

5 Select the file format of the application to which you will export. 

6 Click Browse. 

7 In the Export to Local File Format window, in the File name box, 
name your file. 

8 Choose the location in which to save the file. 

9 Click Save. 

10 In the Export to External Format window, click OK. 

11 In the Business Objects message window indicating that the export 
was successful, click OK. 

12 In the Data Manager window, click OK. 
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Copying a Report to Another Application 

  
Introduction In this topic, you will learn how to copy a report and paste it in another 

application. 

  
Procedure The following table describes how to copy a report and paste it in another 

application: 

 

Step Action 

1 In a report that you want to export, on the Edit menu, click Copy 
All. 

2 In the target application to which you want to export data, open a 
file. 

3 On the Edit menu, click Paste. 
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LESSON C 
USING DOCUMENT EXCHANGE 

Overview 

  
Introduction In this lesson, you will learn how to use Document Exchange. 

  
Lesson 
Objective 

Upon completion of this lesson, you will able to do the following: 
• Send documents to Users 

• Retrieve documents from Users 

• Send documents to Corporate Documents 

• Retrieve documents from Corporate Documents 

• Send documents to Broadcast Agent 

• Retrieve documents from Broadcast Agent 

  
Order of Topics This lesson includes the following topics: 
 

Topic See Page 

Sending a Document to a User 9-12 

Retrieving a Document From a User 9-15 

Sending a Document to Corporate Documents 9-17 

Retrieving a Document From Corporate Documents 9-20 

Sending a Document to Broadcast Agent 9-22 

Retrieving a Document From Broadcast Agent 9-25 
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Sending a Document to a User 

  
Introduction In this topic, you will learn how to send a document to a user. 

  
Description Sending a document to a user simply means that you send a query, report, or 

document of your creation to other Business Objects 5.1.5 users.  The 
Business Objects system administrator must create user groups or user names 
for you to access when sending these documents. 

  
Procedure The following table describes how to send a document to a user: 

 

Step Action 

1 In the Business Objects window, on the File menu, point to Send 
to, and then click Users. 

NOTE: You may also click the Send to Users icon ( ) on the 
Document Exchange toolbar. 

Continued on next page 
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Sending a Document to a User, Continued 

  
Procedure (continued) 
 

Step Action 

2 In the Send window, in the To box, type the group name of the 
users to whom you want to send the document. 

3 Under Document(s) to Send, verify that the correct document is 
listed. 

4 If you need to add a document, click Add. 

Continued on next page 
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Sending a Document to a User, Continued 

  
Procedure (continued) 
 

Step Action 

5 In the Add Documents window, in the list, select the document(s). 

 
6 Click OK. 

7 If you want to retrieve a document stored in another location, click 
Browse. 

8 In the Select the File to Send window, select the document. 

9 Click Add. 

10 If you want to remove a document from the list, click Remove. 

11 Click OK. 

12 In the Results window, click OK. 
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Retrieving a Document From a User 

  
Introduction In this topic, you will learn how to retrieve a document from a user. 

  
Description If a Business Objects EAS IV Repository user sends a document to a user 

group of which you are a member; you will receive notification of reception.  
You then need to retrieve the document in order to view it. 

  
Procedure The following table describes how to retrieve a document from a user: 
 

Step Action 

1 In the Business Objects window, on the File menu, point to 
Retrieve, and then click from Users. 

NOTE: You may also click the Retrieve from Users icon ( ) 
on the Document Exchange toolbar. 

2 In the Retrieve window, in the document list, select the document 
you want to retrieve. 

3 Click Retrieve. 

Continued on next page 
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Retrieving a Document From a User, Continued 

  
Procedure (continued) 
 

Step Action 

4 In the Replace window, do one of the following: 

  If Then  

  You want to over-write the 
existing document 

Click Yes.  

  If you do not want to over-
write the existing document 

a) Click No. 
b) In the Change the File 

name window, in the File 
name box, rename the 
document. 

c) Click Save. 

 

  

5 In the Import Results window, click OK. 
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Sending a Document to Corporate Documents 

  
Introduction In this topic, you will learn how to send a document to Corporate Documents. 

  
Description Sending a document to Corporate Documents publishes the document so that 

any Business Objects 5.1.5 EAS IV Repository user may retrieve the 
document to view or to update. 

  
Procedure The following table describes how to send a document to Corporate 

Documents: 

 

Step Action 

1 In the Business Objects window, on the File menu, point to 
Publish to, and then click Corporate Documents. 

NOTE: You may also click the Publish to Corporate Documents 

icon ( ) on the Document Exchange toolbar. 

Continued on next page 
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Sending a Document to Corporate Documents, Continued 

  
Procedure (continued) 
 

Step Action 

2 In the Send window, under Document(s) to Send, verify that the 
document you want to send is in the list. 

Continued on next page 
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Sending a Document to Corporate Documents, Continued 

  
Procedure (continued) 
 

Step Action 

3 If you want to Add a document, click Add. 

 
4 In the Add Documents window, in the list, select the document(s). 

5 Click OK. 

6 If you want to retrieve a document stored in another location, click 
Browse. 

7 In the Select the File to Send window, select the document. 

8 Click Add. 

9 If you want to remove a document, click Remove. 

10 Click OK. 

11 In the Results window, click OK. 
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Retrieving a Document From Corporate Documents 

  
Introduction In this topic, you will learn how to retrieve a document from Corporate 

Documents. 

  
Procedure The following table describes how to retrieve a document from Corporate 

Documents: 
 

Step Action 
1 In the Business Objects window, on the File menu, point to 

Retrieve From, and then click Corporate Documents. 

NOTE: You may also click the Retrieve from Corporate 
Documents icon ( ) on the Document Exchange 
toolbar. 

2 In the Retrieve window, in the document list, select the document 
you want to retrieve. 

3 Click Retrieve. 

Continued on next page 
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Retrieving a Document From Corporate Documents, Continued 

  
Procedure (continued) 
 

Step Action 

 4 In the Replace window, do one of the following: 

  If Then  

  You want to over-write the 
existing document 

Click Yes.  

  If you do not want to over-
write the existing document 

a) Click No. 
b) In the Change the File 

name window, in the File 
name box, rename the 
document. 

c) Click Save. 

 

  

5 In the Import Results window, click OK. 
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Sending a Document to Broadcast Agent 

  
Introduction In this topic, you will learn how to send a document to Broadcast Agent. 

  
Description Broadcast Agent enables you to schedule documents for processing and 

distribution.  

  
Procedure The following table describes how to send a document using Broadcast 

Agent: 
 

Step Action 

1 In a report, on the File menu, point to Send To, and then click 
Broadcast Agent. 

NOTE: You may also click the Sent to Broadcast Agent icon 
( ) on the Document Exchange toolbar. 

2 In the Send Document to Broadcast Agent window, in the Server 
box, click the down arrow. 

Continued on next page 
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Sending a Document to Broadcast Agent, Continued 

  
Procedure (continued) 
 

Step Action 

3 In the list, select the server name you want. 

4 If you want to set a priority other than normal, in the Priority box, 
click the down arrow. 

5 In the list, select a priority. 

6 Click the Actions tab. 

7 Under Standard Actions, in the Available actions list, select any 
actions that you want. 

8 Click Add. 

9 Click the Scheduling tab. 

Continued on next page 
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Sending a Document to Broadcast Agent, Continued 

  
Procedure (continued) 
 

Step Action 

10 If you want to schedule the document to send other than one time, 
click Change. 

11 In the Change Schedule window, under Run, click the frequency 
you want. 

12 Under Start At, fill in the corresponding information. 

13 Click OK. 

14 In the Send Document to Broadcast Agent window, click OK. 
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Retrieving a Document From Broadcast Agent 

  
Introduction In this topic, you will learn how to retrieve a document from Broadcast 

Agent. 

  
Procedure The following table describes how to retrieve a document from Broadcast 

Agent: 
 

Step Action 
1 In a report, on the File menu, point to Retrieve From, and then 

click Broadcast Agent. 

NOTE: You may also click the Retrieve from Broadcast Agent 
icon ( ) on the Document Exchange toolbar. 

2 In the Retrieve window, in the document list, select the document 
you want to retrieve. 

3 Click Retrieve. 

Continued on next page 
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Retrieving a Document From Broadcast Agent, Continued 

  
Procedure (continued) 
 

Step Action 

 4 In the Replace window, do one of the following: 

  If Then  

  You want to over-write the 
existing document 

Click Yes.  

  If you do not want to over-
write the existing document 

a) Click No. 
b) In the Change the File 

name window, in the File 
name box, rename the 
document. 

c) Click Save. 

 

  

5 In the Import Results window, click OK. 
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UNIT 10 
WORKSTATION INSTALLATION 

Overview 

   
Introduction In this unit, you will learn how to install the software required to run the 

EAS IV Repository on a client workstation. 

  
Unit Objective Upon completion of this unit, you will be able to do the following: 

• Install Informix Client Connect software on a workstation 

• Configure Informix Client Connect software on a workstation 

• Install Business Objects 5.1.5 on a workstation 

• Configure Business Objects 5.1.5 workstation software to allow 
access to the EAS IV Repository 

  
In This Unit This unit includes the following lessons: 
 

Lesson See Page 

Installation Checklist 10-2 

Lesson A:  Installing and Configuring Informix Client 
Connect Software 

10-3 

Lesson B:  Installing and Configuring Business Objects 5.1.5 10-23 

  



EAS IV Repository Functional User’s Guide 
 

May 2003 10-2 105-03-001 

INSTALLATION CHECKLIST 

  
Introduction In this topic, you will learn about hardware, software, and security 

requirements that you must gather before you begin installation.  Be sure to 
obtain the products or information listed in the steps before beginning 
installation. 

  
Procedure Verify that you have all of the items in the following table before beginning 

installation: 

 

 Workstation Hardware  ✓  

A 200 MHz Pentium computer with 3.1 GB hard drive capacity 
and CD-ROM or equivalent, and a minimum of 64 megabytes 
(MB) of random access memory (RAM)  

 

A compatible monitor, keyboard, and mouse  

Workstation Software   

Preloaded Windows NT 4.0 with Service Pack 5 and Windows 
NT Workstation Resource Kit (preferred) 

(Optional Windows 95 or 98) 

 

Business Objects 5.1.5  

Informix Client Connect 9.1.4 or higher  

EAS IV Repository floppy disk with Bomain key  

Installation Items  

EAS IV Repository Functional User’s Guide or Using the EAS IV 
Repository 

 

EAS IV Repository Security Packet  

Administrator ID and password for the workstation operating 
system 

 

User ID and password for the workstation operating system  

User ID and password for the EAS IV Repository  
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LESSON A 
INSTALLING AND CONFIGURING INFORMIX CLIENT 

CONNECT SOFTWARE 

Overview  

  
Introduction In this lesson, you will learn how to install and configure Informix Client 

Connect, Version 9.1.4 or greater, on a client workstation.  Informix Client 
Connect resides on a workstation and provides an application-level 
connection to the HP-UX Informix Dynamic Server (IDS), a relational 
database engine that enables the EAS IV Repository HP-UX and Windows 
NT servers to maintain a highly sophisticated collection of data.  The IDS 
houses all the EAS IV Repository data. 

NOTE: Any references to installation drive letters are the suggested drives 
to use; however, you may install on the drive of your choice. 

  
Lesson 
Objectives 

Upon completion of this lesson, you will be able to do the following: 
• Verify or add a service port number 

• Set up the Hosts file 

• Install Informix Client Connect on a client workstation 

• Configure Informix Client Connect on a client workstation 

• Test workstation connectivity to the database 

  
Order of Topics This lesson includes the following topics: 

 

Topic See Page 

Verifying or Adding a Service Port Number 10-4 

Setting Up the Hosts File 10-8 

Installing Informix Client Connect 10-10 

Configuring Informix Client Connect 10-12 

Testing Database Connectivity 10-15 
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Verifying or Adding a Service Port Number 

  
Introduction In this topic, you will learn how to verify or add a service port number. 

  
Procedure The following table describes how to verify or add a service port number: 
 

Step Action 

1 Log on to the client workstation as an administrator under the local 
machine name. 

2  

  If Then  

  The operating system is 
Windows NT 

a) Click Start, point to 
Programs, and then click 
Windows NT Explorer. 

b) In the Exploring window, 
open the 
C:\Winnt\system32\ 
drivers\etc folder. 

c) In the etc folder, double-
click the Services file. 

 

  The operating system is 
Windows 95 or 98 

a) Click Start, point to 
Programs, and then click 
Windows Explorer. 

b) In the Explorer window, 
open C:\Services\etc. 

c) In the etc folder, double-
click the Services file. 

 

  

Continued on next page 
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Verifying or Adding a Service Port Number, Continued 

  
Procedure (continued) 
 

Step Action 

3 In the Open With window, select NOTEPAD. 

4 Click OK. 

5 In the Services-Notepad window, on the Search menu, click Find. 

6 In the Find window, type the service file name listed under Service 
File Information in the EAS IV Repository Security Packet. 

7 Under Direction, click Down. 

Continued on next page 
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Verifying or Adding a Service Port Number, Continued 

  
Procedure (continued) 
 

Step Action 

8 Click Find Next. 

9  

  If Then  

  The Find functions finds 
sqlexec 1540/tcp 

a) In the Find window, click 
Cancel. 

b) Go to step 23. 

 

  The message, Cannot find 
“sqlexec,” appears 

Go to step 10.   

  

10 In the Notepad window, click OK. 

11 In the Find window, select sqlexec. 

12 Type maze. 

13 Click Find Next. 

14 Click Cancel. 

14 In the Notepad-Services window, place the cursor to the left of the 
line:  maze 1666/udp. 

15 Press Enter. 

16 Place the cursor at the beginning of the blank line above maze 
1666/udp. 

17 Type the service file name listed under Service File Information in 
the EAS IV Repository Security Packet. 

18 Align the cursor with the port number column. 

19 Type the port number and protocol listed under Service File 
Information in the EAS IV Repository Security Packet. 

20 Align the cursor with the comment column. 

Continued on next page 
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Verifying or Adding a Service Port Number, Continued 

  
Procedure (continued) 
 

Step Action 

21 Type # MEQS III and EAS IV Repository. 

22 On the File menu, click Save. 

23 On the File menu, click Exit. 
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Setting Up the Hosts File 

  
Introduction In this topic, you will learn how to set up the Hosts file. 

   
Procedure The following table describes how to set up the Hosts file: 
  

Step Action 
1 In the Exploring window, in the etc folder, double-click the Hosts 

file. 

2 In the Open With window, double-click Notepad. 

3 In the Hosts-Notepad window, under For example, in the IP 
address column, type the IP address for the first EAS IV 
Repository server listed under Host File Information in the EAS IV 
Repository Security Packet. 

4 Tab to the server name column, and type the first server name 
listed under Host File Information in the EAS IV Repository 
Security Packet. 

5 Tab to the IP name column, and type the IP name for the first 
server listed under the Host File Information in the EAS IV 
Repository Security Packet. 

6 Press Enter. 

7 In the IP address column, type the IP address for the second server 
name listed under Host File Information in the EAS IV Repository 
Security Packet. 

8 Tab to the server name column, and type the second server name 
listed under Host File Information in the EAS IV Repository 
Security Packet. 

9 Tab to the IP name column, and type the IP name for the second 
server listed under Host File Information in the EAS IV Repository 
Security Packet. 

10 Press Enter. 

Continued on next page 
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Setting Up the Hosts File, Continued 

 
Procedure (continued) 
 

Step Action 

11 In the IP address column, type the IP address for the third server 
name listed under Host File Information in the EAS IV Repository 
Security Packet. 

12 Tab to the server name column, and type the third server name 
listed under Host File Information in the EAS IV Repository 
Security Packet. 

13 Tab to the IP name column, and type the IP name for the third 
server listed under Host File Information in the EAS IV Repository 
Security Packet. 

14 On the File menu, click Save. 

15 On the File menu, click Exit. 
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Installing Informix Client Connect 

  
Introduction In this topic, you will learn how to install Informix Client Connect. 

NOTE: You only need to install this version of Informix if you currently do 
not have this version on your workstation. 

  
Prerequisite You must be logged on to the client workstation as an administrator under the 

local machine name. 

  
Procedure The following table describes how to install Informix Client Connect: 

 

Step Action 

1 Place the Informix CD-ROM in the CD-ROM drive. 

2  

  If Then  

  The operating system is 
Windows NT 

a) Right-click Start, and then 
click Explore. 

b) In the Exploring window, 
open the <CD-ROM drive 
letter>:\Iconnect\Win_nt 
95\setup.exe program. 

 

  

3 In the Enter Serial# and Key window, in the Serial# box, type the 
serial number. 

4 In the Key box, type the serial number key. 

5 Click Next. 

6 In the Installation Options window, click Next. 

7 In the Select Folder For Informix Applications window, click Next.

8 In the Ready To Install Files window, click Next. 

Continued on next page 
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Installing Informix Client Connect, Continued 

  
Procedure (continued) 
 

Step Action 

9 In the C:\WINNT\Profiles\All Users\Start 
Menu\Programs\Informix window, on the File menu, click Close. 

10 In the Setup Complete window, click Finish. 

11 Remove the CD-ROM from the drive. 

12 In the Exploring window, open C:\Informix\bin. 

13  

  If Then  

  The isqlt07c.dll file exists Go to step 14.  

  The isqlt07c.dll file does not 
exist 

a) On the File menu, point to 
New, and then click 
Folder. 

b) In the new folder title box, 
type isqlt07c.dll. 

c) Right-click the 
isqlt07c.79x file. 

d) On the menu, click Copy. 
e) Open the isqlt07c.dll 

folder. 

f) On the File menu, click 
Paste. 

 

  
14 On the File menu, click Close. 
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Configuring Informix Client Connect 

  
Introduction In this topic, you will learn how to configure Informix Client Connect. 

  
Prerequisite You must be logged on to the client workstation as an administrator under the 

local machine. 

  
Procedure The following table describes how to configure Informix Client Connect: 
 

Step Action 

1 Click Start, point to Programs, point to Informix, and then click 
Informix Setnet32. 

2 Click the Server Information tab. 

3 In the Informix Server box, type the first server name listed under 
Informix Client Connect Information in the EAS IV Repository 
Security Packet. 

4 In the Hostname box, type the host name of the first server listed 
under Informix Client Connect Information in the EAS IV 
Repository Security Packet. 

5 In the Protocolname box, click the down arrow. 

6 In the list, select the protocol name listed under Informix Client 
Connect Information in the EAS IV Repository Security Packet. 

7 In the Service name box, type the service file name listed under 
Service File Information in the EAS IV Repository Security Packet. 

NOTE: If there is any information in the Options box, select it 
and then press Delete. 

8 Click Make Default Server. 

9 Click Apply. 

10 In the Informix Setnet32 window, click OK. 

11 Click the Host Information tab. 

Continued on next page 
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Configuring Informix Client Connect, Continued 

  
Procedure (continued) 
 

Step Action 

12 In the Current Host box, ensure that the host name you typed in 
step 4 appears. 

13 In the User Name box, type the user name listed under Informix 
Client Connect Information in the EAS IV Repository Security 
Packet. 

14 In the Password Option box, select Password. 

15 In the Password box, type the user password listed under Informix 
Client Connect Information in the EAS IV Repository Security 
Packet. 

16 Click OK. 

17 In the Informix Setnet32 window, click OK. 

18 Click Start, point to Programs, point to Informix, and then click 
Informix Setnet32. 

19 Click the Server Information tab. 

20 In the Informix Server box, type the name of the second server 
listed under Informix Client Connect Information in the EAS IV 
Repository Security Packet. 

21 In the Hostname box, type the host name of the second server 
listed under Informix Client Connect Information in the EAS IV 
Repository Security Packet. 

22 In the Protocolname box, click the down arrow. 

23 In the list, select the protocol listed under Informix Client Connect 
Information in the EAS IV Repository Security Packet. 

Continued on next page 
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Configuring Informix Client Connect, Continued 

  
Procedure (continued) 
 

Step Action 

24 In the Service name box, type the service file name listed under 
Service File Information in the EAS IV Repository Security Packet.

25 Click Make Default Server. 

26 Click Apply. 

27 In the Informix Setnet32 window, click OK. 

28 Click the Host Information tab. 

29 In the Current Host box, ensure that the host name you typed in 
step 4 appears. 

30 In the User Name box, type the user name listed under Informix 
Client Connect Information in the EAS IV Repository Security 
Packet. 

31 In the Password Option box, select Password. 

32 In the Password box, type the user password listed under Informix 
Client Connect Information in the EAS IV Repository Security 
Packet. 

33 Click OK. 

34 In the Informix Setnet32 window, click OK. 

35 Click Start, and then click Shut Down. 

36 In the Shut Down Windows window, click Restart the computer?. 

37 Click Yes. 
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Testing Database Connectivity 

  
Introduction In this topic, you will learn how to test database connectivity. 

  
Prerequisite You must be logged on to the client workstation as an administrator under the 

local machine name for the domain. 

  
Procedure The following table describes how to test database connectivity: 
 

Step Action 

1 Click Start, and then click Run. 

2 In the Run window, in the Open box, type ilogin. 

3 Click OK. 

4  

  If Then  

  Your operating system is 
Windows 95 or 98 and the 
message, Cannot find the file 
‘ilogin,’ appears 

Go to step 15.  

  Your operating system is 
Windows NT and the 
message, Cannot find the file 
‘ilogin,’ appears 

Go to step 5.  

  The Ilogin Demo for 
Informix-Connect for Win32 
window appears 

Go to step 32.  

  

5 Click OK. 

6 Click Start, point to Informix, and then click Setnet32. 

7 In the Setnet32 window, on the Environment tab, in the Informix 
Client/Server Environment list, select INFORMIXDIR=. 

8 Under Edit Environment Variable, in the box, type C:\Informix. 

Continued on next page 
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Testing Database Connectivity, Continued 

  
Procedure (continued) 
 

Step Action 

9 Click Set. 

10 In the Informix Client/Server Environment list, select 
INFORMIXSERVER=. 

11 Under Edit Environment Variable, in the box, type the name of the 
first server listed under Informix Client Connect Information in the 
EAS IV Repository Security Packet. 

12 Click Set. 

13 Click OK. 

14 Return to step 1. 

15 Click OK. 

16 Click Start, point to Programs, point to Accessories, and then click 
Notepad. 

17 In the <Untitled> - Notepad window, on the File menu, click Open.

18 In the Look in box, select the C drive. 

19 In the Files of type box, select All Files. 

20 In the list, select autoexec.bat. 

21 Click Open. 

Continued on next page 
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Testing Database Connectivity, Continued 

  
Procedure (continued) 
 

Step Action 

22 Position the cursor at the bottom of the file. 

23 Type the following: 

SET PATH=C:\INFORMIX\bin;%PATH% 

SET INFORMIXDIR=C:\INFORMIX 

24 On the File menu, click Save. 

25 On the File menu, click Exit. 

26 Click Start, and then click Shut Down. 

27 In the Shut Down Windows window, click Restart the computer?. 

28 Log on to the client workstation as an administrator under the local 
machine name. 

29 Click Start, and then click Run. 

30 In the Run window, in the Open box, type ilogin. 

31 Click OK. 

32 In the ILogin Demo for INFORMIX – Connect for Win32 window, 
on the File menu, click Run. 

33 In the Login Parameters window, in the Server box, type the name 
of the first server listed under Informix Client Connect Information 
in the EAS IV Repository Security Packet. 

34 In the Hostname box, type the host name of the first server listed 
under Informix Client Connect Information in the EAS IV 
Repository Security Packet. 

35 In the Service Name box, type the service file name listed under 
Service File Information in the EAS IV Repository Security Packet. 

36 In the Protocolname box, type the protocol listed under Informix 
Client Connect Information in the EAS IV Repository Security 
Packet. 

Continued on next page 
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Testing Database Connectivity, Continued 

  
Procedure (continued) 
 

Step Action 

37 In the Username box, type the user name t listed under Informix 
Client Connect Information in the EAS IV Repository Security 
Packet. 

38 In the Password box, type the user password for listed under 
Informix Client Connect Information in the EAS IV Repository 
Security Packet. 

39 In the Stores Database box, clear the information. 

40 Click OK. 

41  

  If Then  

  An error message appears a) Click OK. 
b) Return to step 32, and 

verify that you entered all 
the information exactly as 
it appears in these 
instructions. 

 

  The Customer Records Found 
window appears 

Go to step 52.  

  An error message appears, 
and you already verified that 
all the information was 
entered exactly as it appears 
in these instructions 

Go to step 42.  

  

Continued on next page 
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Testing Database Connectivity, Continued 

  
Procedure (continued) 

 

Step Action 

42 Write the error number on a piece of paper. 

43 In the ILogin Demo for INFORMIX – Connect for Win32 window, 
on the File menu, click Exit. 

44 In the Message from ILogin Demo window, click Yes. 

45 Click Start, point to Programs, point to Informix, and then click 
Find Error. 

46 In the Informix Error Messages window, click Search. 

47 In the Help Topics: Informix Error Messages window, select the 
number of the error that appeared. 

48 Click Display. 

49 Click Go To. 

50 In the Informix Error Messages window, read the description of the 
error. 

51  

  If Then  

  You know how to correct the 
error 

a) Correct the error. 

b) Return to step 29. 

 

  You do not know how to 
correct the error 

a) Contact your 
administrator for help 
solving the error. 

b) Return to step 29. 

 

  

52 In the Customer Records Found window, click OK. 

53 In the ILogin Demo for INFORMIX – Connect for Win32 window, 
on the File menu, click Run. 

Continued on next page 
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Testing Database Connectivity, Continued 

  
Procedure (continued) 
 

Step Action 

54 In the Login Parameters window, in the Server box, type the name 
of the second server listed under Informix Client Connect 
Information in the EAS IV Repository Security Packet. 

55 In the Hostname box, type the host name of the second server listed 
under Informix Client Connect Information in the EAS IV 
Repository Security Packet. 

56 In the Service Name box, type the service file name listed under 
Service File Information in the EAS IV Repository Security Packet. 

57 In the Protocolname box, type the protocol listed under Informix 
Client Connect Information in the EAS IV Repository Security 
Packet. 

58 In the Username box, type the user name listed under Informix 
Client Connect Information in the EAS IV Repository Security 
Packet. 

59 In the Password box, type the user password listed under Informix 
Client Connect Information in the EAS IV Repository Security 
Packet. 

60 In the Stores Database box, clear the information. 

61 Click OK. 

Continued on next page 
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Testing Database Connectivity, Continued 

  
Procedure (continued) 
 

Step Action 

62  

  If Then  
  An error message appears a) Click OK. 

b) Return to step 54, and 
verify that you entered all 
the information exactly as 
it appears in these 
instructions. 

 

  The Customer Records Found 
window appears 

Go to step 73.  

  An error message appears, 
and you already verified that 
all the information was 
entered exactly as it appears 
in these instructions 

Go to step 63.  

  
63 Write the error number on a piece of paper. 

64 In the ILogin Demo for INFORMIX – Connect for Win32 window, 
on the File menu, click Exit. 

65 In the Message from ILogin Demo window, click Yes. 

Continued on next page 
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Testing Database Connectivity, Continued 

  
Procedure (continued) 
 

Step Action 

66 Click Start, point to Programs, point to Informix, and then click 
Find Error. 

67 In the Informix Error Messages window, click Search. 

68 In the Help Topics: Informix Error Messages window, select the 
number of the error that appeared. 

69 Click Display. 

70 Click Go To. 

71 In the Informix Error Messages window, read the description of the 
error. 

72  

  If Then  

  You know how to correct the 
error 

a) Correct the error. 
b) Return to step 53. 

 

  You do not know how to 
correct the error 

a) Contact your 
administrator for help 
solving the error. 

b) Return to step 53. 

 

  

73 In the Customer Records Found window, click OK.  

74 In the ILogin Demo for INFORMIX – Connect for Win32 window, 
on the File menu, click Exit. 

75 In the Message form ILogin Demo window, click Yes. 
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LESSON B 
INSTALLING AND CONFIGURING BUSINESS OBJECTS 5.1.5 

Overview  

  
Introduction In this lesson, you will learn how to install and configure Business Objects 

5.1.5 on a client workstation.  Business Objects 5.1.5 is a software product 
that queries EAS IV Repository data, formats the data in reports, and supplies 
multiple methods to analyze the data. 

NOTE: Any references to installation drive letters are the suggested drives 
to use; however, you may install on the drive of your choice. 

  
Definition Business Objects 5.1.5 is a COTS software product that provides the EAS IV 

Repository end-user with a Microsoft Windows GUI for data access and 
decision support.  The application stores EAS IV Repository data and refers 
to them as objects.  Objects are grouped logically into classes, and classes are 
grouped into universes.  The universe and class names enable Business 
Objects 5.1.5 to locate queried data to format the data in a report. 

  
Lesson 
Objective 

Upon completion of this lesson, you will be able to do the following: 
• Install Business Objects 5.1.5 on a client workstation 

• Configure Business Objects 5.1.5 on a client workstation 

  
Order of Topics This lesson includes the following topics: 

 

Topic See Page 

Installing Business Objects 5.1.5 10-24 

Setting Up a Business Objects 5.1.5 Shortcut 10-27 

Setting Up the Business Objects Report Module 10-28 
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Installing Business Objects 5.1.5 

  
Introduction In this topic, you will learn how to install Business Objects 5.1.5. 

NOTE: You only need to install this version of Business Objects if you 
currently do not have this version on your workstation. 

  
Prerequisite You must be logged on to the client workstation as an administrator under the 

local machine name for the domain. 

  
Procedure The following table describes how to install Business Objects 5.1.5: 

 

Configuring Windows 2000 for BusinessObjects 5.1.5 users 
to access  

NOTE:   THIS UTILITY SHOULD ONLY BE INSTALLED ON WINDOWS 2000                  
CLIENT WORKSTATIONS 

Perform the following steps to execute the AllowBo51-26-W2000 Utility: 

Step Action 

1 Log on as the administrator on the local client machine 

2 Click Start, then Settings, then Control Panel 

3 Double-click on the Users and Passwords icon 

4 On the Users and Passwords window, for each user listed as a 
Power User, you must remove them from the Power Users 
Group.  To remove Users from the Power User group, select the 
User and click the Remove button. 

NOTE:  If there are not any Users in the Power User Group, 
proceed with the next   step. 

5 On the Users and Passwords window, click the OK button 

6 Press the Control, ALT and Delete keys simultaneously 

7 Click on the Task Manager button 
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Step Action 

8  On the Task Manager window click on the Processes tab 

9 Click on Start, then Run, then Browse 

10 Locate and select the file “Allow B051-26-W2000.exe” on the 
EAS IV 2.4.0.0 Compact disk. 

11 On the Browse window, click the Open button 

12 On the Run window, click the OK button 

13 In the Task Manager window, locate the file AllowB051-
26W2000.exe in the Image Name column. 

14 When the AllowBo51-26-W2000.exe file disappears, close the 
Task Manager window. 

15 The Utility is finished 

 

Installing BusinessObjects 5.1.5 Software 

Perform the following steps to install the BusinessObjects 5.1.5 software: 

Step Action 

1 

Insert BusinessObject CD Volume 1 
NOTE:  If the setup program does not start automatically, click 
on Start, Run, then select Browse to the CD ROM drive.  Then 
launch the setup.exe located in the setup folder. 

2 On the BusinessObjects Setup-Welcome window, click the 
Begin button 

3 
On the BusinessObjects Setup-Overview window, click the 

Next button 

4 On the BusinessObjects Setup-Step #1 window, type in your 
name and the name of the organization 

5 Click the Next button 

6 On the BusinessObjects Setup- Step #2 window type in your 
Product Key and Data Access Key 

7 Click the Next button 
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Step Action 

8 On the BusinessObjects Setup – Step #3 window, click the ‘I 
AGREE’ button. 

9 On the BusinessObjects Setup-Step #4 window, select the 
Stand-Alone Setup option 

10 Click the Next button 

11 On the BusinessObjects Setup-Step #5 window, select the 
Custom option 

12 Click the Next button 

13 On the BusinessObjects Setup-Step #6 window, verify that the 
option for keeping your existing 4.x installation is selected    

14 Click the Next button 

15 
On the BusinessObjects Setup-Step #7 window, verify that the 
Main BusinessObjects folder is C:\Program Files\Business 
Objects 

16 
On the Business Objects Setup-Step #7 window, verify that the 
BusinessObjects Shared folder is C:\Program Files\Business 
Objects\BusinessObjects 5.0\ShData 

17 Click the Next button 

18 
If a message pops up asking “C:\program files\Business 
Objects\BusinessObjects 5.0 does not exist.  Do you want to 
create it?” , Click the YES button 

19 On the BusinessObjects Setup- Step #8 window, make sure that 
the only options checked are BusinessObjects and Multimedia 

20 Click the Install button 

21 If a window appears prompting you to close all other windows, 
do so and click the OK button 
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Step Action 

22 

On the Insert Disk window, click the OK button after you insert 
the Business Objects Volume 2 CD 

          NOTE:  System Administrator will be required to 
wait several minutes  prior to continuing the 
software installation after loading the 
Business Objects Volume 2 CD.  This will 
give Windows time to recognize the CD 
properly.  

23 
On the Business Objects Setup window, click the Yes button if 
you wish to view the Readme.txt file, otherwise click the No 
button 

24 
If you view the ReadMe.txt file, close it when you are finished  

viewing the file 

25 On the BusinessObjects Setup window, click the Yes button to 
check the middleware 

26 

Verify the following information in one of the sections: 

       
___________________________________________________ 

Starting to check if the middleware components are correctly installed (Informix 
Connect v7, INFORMIX). 
 
INFORMIXDIR... ok. 
INFORMIXSERVER... ok. 
HKEY_LOCAL_MACHINE\SOFTWARE\Informix\SqlHosts\eas4_svr... ok. 
Path... ok. 
isqlt07c.dll... ok. 
 
The middleware checking has not detected any errors (Informix Connect v7, 
INFORMIX). 
________________________________________________________________________ 

       

    NOTE:  If the text above does not appear on your 
workstation, complete Section          

                  D.11.3 “Configuring the Informix Client Connect 
Software (SetNet32)”. 

 

27 On the Business Objects Setup window, click the OK button 

28 If prompted to restart/reboot your client workstation, do so 
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Setting Up a Business Objects 5.1.5 Shortcut 

  
Introduction In this topic, you will learn how to set up the Business Objects 5.1.5 shortcut. 

  
Prerequisite You must be logged on to the client workstation as an administrator under the 

local machine name for the domain. 

  
Procedure The following table describes how to set up the Business Objects 5.1.5 

shortcut: 
 

Step Action 

1 Right-click the Start menu, and then click Explore. 

2 Open the C:\Program Files\Business Objects\Business Objects 
5.1.5 folder. 

3 Right-click the Busobj.exe file, and then click Create Shortcut. 

4 Drag the new shortcut to the desktop. 
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 Setting Up the Business Objects Report Module 

  
Introduction In this topic, you will learn how to set up the Business Objects report module. 

  
Prerequisite You must ensure that the Business Objects administrator for your Service 

establishes your EAS IV Repository Business Objects user account and User 
ID in the Business Objects Supervisor module before you can set up the 
Business Objects report module. 

You must be logged on to the client workstation as the EAS IV Repository 
user under the domain. 

  
Procedure The following table describes how to set up the Business Objects report 

module: 

 

Step Action 

1 On the desktop, double-click the Business Objects 5.1.5 icon. 

2 In the User Identification window, in the User Name box, type the 
user’s Business Objects login ID. 

3 In the Password box, type the user’s Business Objects password. 

4 Click OK. 

5 In the New Report Wizard window, clear Run this Wizard at 
Startup. 

6 Click Cancel. 

7 In the Business Objects window, on the Tools menu, click 
Universes. 

8 In the Universes window, in the list, select the EAS IV Repository 
universe. 

9 Click Import. 

10 In the Import Universe window, click OK. 

 


